IP change seems to have worked but still seeing old website

Our old host has flaked and is nowhere to be found. They had set up a free Cloudflare account for the domain.

I redesigned the site on a new host and then found instructions for how to create a new Cloudflare account when you don’t have access to the old one. I created a new one, changed the IP to new host, and changed nameservers to new Cloudflare account. It all seemed to work fine.

It has been about 24 hrs and the old site is still showing up and my sense is there is something else that needs to happen. (I looked at other related posts but they all end before the resolution is posted it seems.) Reading other posts I am not sure this will resolve itself if I just wait so wanted to post about it for advice.
I see in another post someone replied to contact the old host and " you need to ask them to completely clear your domain from their settings and their Cloudflare integration". But what to do if you have no way to contact them???

Would it make any difference to change the TTL? (Also, when is too soon to purge the Cloudflare cache and would it help anything?)

Thanks for any pointers.

I meant to also add that there is another domain that I pointed to the same new host IP and redirected to a particular page of the website, and it is working, so the nameservers must have propagated for the new hosting. But it goes to that page on the old site (same url). So it seems the IP is working but the site version is still being served from old site.

domain is raphaologyhealing.com in case anyone asks. (leaving out the com since links not allowed)

(the other domain is ineedherbs, now pointing to the new IP /health-catalog page).

Hope I’m making sense.

x-powered-by: WP Engine

Looking at the HTTP headers, might be some kind of an integration setup for your domain name since before :thinking:

If that is the case, then kindly I’d suggest you to use the below article and the tool mentioned inside it to resolve your naked domain non-www and www hostname with it. Below article describes more in detail about this issue, if that’s your case too as it sounds to me:

Use the tool called “Liberate the Hostname” from the article below and repeat the process using below tool for both www.domain.tld and naked domain.tl just in case:

I’d suggest you to clear the cache at your origin host, at least what I can see by the HTTP cache headers :thinking:

cache-control: max-age=600, must-revalidate
x-cacheable: SHORT
x-cache-group: normal
x-cache: HIT: 3

Furthermore, may I ask you to check out what option have you got selected by navigating to the Cloudflare dashboard → Caching → Configuration → find section “Browser Cache TTL” and make sure the selected option from the dropdown menu is “Respect Existing Headers”.

Furthermore, from the same menu, click on the blue button saying “Purge Everything” to flush the cache at Cloudflare Edge, just in case.

Wait for a minute or two.

Refresh a page in your Web browser, otherwise try clearing your Web browser cache or use a different Web browser to test out again.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Other helpful articles:

Thanks for the lengthy reply!

I just referred to the article you linked to and followed the instructions in #1 under 'what if a provider does not offboard my domain". I contacted new host (siteground) and they added the HTTP ownership_verification record.

I waited 5 minutes, then followed your advice to change in Cloudflare Browser Cache TTL to ‘respect existing headers’.

Then I purged everything.

Still seeing the old host site. Yes tried on 3 browsers, plus 4 browsers on phone (including duck duck go).

Shall I use the ‘liberate your domain’ tool now? (love the name : )
(One question about that tool: it says point the hostname to your new provider at the end of step 3 but that’s already done. Can I leave all that in place, just add the couple DNS records they give for verification, then delete, but leave the A records I already created is fine during that process?)

NVM the last question. I figured that out and got the lovely ‘liberated’ note.
Still seeing the old site but will wait a bit and check again.

THANK YOU! Delighted to say it is resolved.
Just to let you know: After all that was done, I was getting SSL error (ERR_SSL_VERSION_OR_CIPHER_MISMATCH on Chrome, SSL_ERROR_NO_CYPHER_OVERLAP on Firefox).
I turned off proxied for a while and then everything seemed to work.
Before that I also added a rule to Cloudflare that I don’t know if I needed or not, just in case (saw it on a YT video) for http://domain.com/
Always use HTTPS
Do you think that is good to have there or redundant?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.