IP block on WAF not working

### Answer these questions to help the Community help you with Security questions. ###

*What is **the domain name**?*

*Have you searched for an answer?*

*Please share your search results url:*

*When you tested your domain using the [Cloudflare Diagnostic Center](`https://www.cloudflare.com/diagnostic-center/`), what were the results?*
`https://www.cloudflare.com/diagnostic-center/` does not exist, it redirects to `https://support.cloudflare.com/hc/en-us`

*Describe the issue you are having:*
I am testing blocking my own ip from access our staging environment, (https://staging.betprophet.co), by adding a WAF rule, however I am still able to access our staging as usual. It has being about 10 minutes after I added the WAF rule.

*Have you tried from another browser and/or incognito mode?*
Yes, still not blocking me.

Please attach a screenshot of the error:

I believe I found the reason. It is because our website is using CNAME record forward to a AWS elb, rather a A record proxy to a static ip address, so the WAF is not working.

Please do correct me if my understanding is wrong. Thanks,

Correct, the record needs to be :orange: for WAF to be able to run.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.