IP address of nameserver is missing

I received a dmarc report from Google indicating a problem with my website. When I ran a “Check MX” report inside Google Admin Toolbox, I received this critical error message: “We were not able to find a single IP address of nameserver serving this domain. Mail-flow is probably affected. Please refer to the corresponding help articles to fix these.” The help articles said to check with my domain provider (Namecheap) and they said to contact Cloudflare for support because they handle my DNS.

I haven’t noticed any problems with my website or mail delivery so far. But its a new newsletter with few subs right now. So I’m afraid this might become an issue as the list grows if I dont fix the problem. Can someone point me in the right direction to fix this?

I’ve attached a screenshot of the MX report to view.

1 Like

That’s a bit weird :thinking:

I am also using Namecheap privateemail for multiple domains.

I do see MX are set okay and pointed to namecheap for your domain and nameservers too.
Domain status is ok.
DNSSEC not used.

Nevertheless, in case you need to find IP of the nameservers which are assigned to your Cloudflare account and used in your zone, please see below article:

To satisfy DMARC, you’d have to add 3 TXT records:

  1. for SPF provided from Namecheap
  2. for DKIM provided from Namecheap interface
  3. for DMARC policy

From my example, please double-check yours’ and see mine’s correct ones from below picture of DNS settings while using Namecheap’s Privatemail:

Useful and helpful article from Namecheap:

Adding the DKIM value and the IP from your other server into the TXT (for SPF), without DMARC should work if the TXT (for SPF) would have ?all (neutral) → neutral for testing purposes at least for first time.

Also the A mail.billywittenberg.com is proxied :orange:. Please, switch this to :grey: (DNS-only).

When you’re using your email client, MS Outlook, Mozilla Thunderbird, etc., which server are you using to sent out email that is causeing you the issue with e-mail? How did you configured your email client to talk to your MTA? Does it use Privatemail’s credentials and pop/imap/smtp, or rather some other?


Thanks for the reply

I set my email settings to DNS only, same as yours. And I added the DKIM record. Everything seems fine there.

I then tried to add A records with my IP addresses, found on digwebinterface.com. I got this error message for all six IP addresses. "A CNAME record with that host already exists. (Code: 81054)

I’m still receiving the same dmarc report with the same MX report that I attached in my previous post.

1 Like


Would you try modifying the DKIM record? Policy is set to none. Instead set it to reject.

Are you using Google workspace for your email? If yes, only then use Google Admin Tools. Else, it’ll show the possible errors.

Instead check via DMARCIAN

From your screenshot, it looks like you entered https://billywittenberg.com instead of just the domain name itself: billywittenberg.com.

Please try that instead.

Then it’s a safe bet you have a CNAME record that’s conflicting with this.

@neiljay probably meant the DMARC record.

I’m not finding a standard DKIM record:

@Mac –> dig TXT default._domainkey.billywittenberg.com

; <<>> DiG 9.10.6 <<>> TXT default._domainkey.billywittenberg.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 12741
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1
1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.