Invite to manage email link is not working

the email is sent to the correct email, but when i click on the link it says the invitation is not for the email address it was sent to.

invitation email sent to [email protected]
when I click on the link, it says the invite is not for [email protected]

Were you able to resolve this @sean38?

issue remains.

issue has been resolved.
don’t know how, he sent yet another link today and it worked.

1 Like

email: You have been invited to join and manage an account on Cloudflare
website: This invitation is not for

Client sent me an invitation to manage their DNS.
the invite is sent to [email protected]
I recevie the email.
I click on the link and the CF website says:
This invitation is not for [email protected]
that’s kinda odd. Haven’t seen this before and my searches didn’t find this exact issue.

  1. I tried clearing cache, using PrivateBrowing, in Edge and Firefox. No change.
  2. he removed the invite on his side and recreated it. No change.

issue resovled.
don’t know how.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.