Invitation to manage account returns obscure error

A client has added me to their Cloudflare account, and I received the invitation email. Clicking on the link in that email takes me to a page where I am asked to join the client’s team or decline the invite. Clicking join leads to a blank page with the following error message at the bottom:

“Membership not found (Code: 1003)”

I have searched for more information about this issue, but have not found anything. Even the API documentation is virtually silent as to what the error means. Any help would be appreciated.

Did you contacted the Cloudflare account owner if he/she might removed you and if that invitation link possibly in this case doesn’t work anymore? :thinking:

Otherwise, kindly ask the to re-add you again and try again, if already not.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

If it happens again, I’d suggest you and/or Cloudflare account owner to write a ticket to Cloudflare Support about it for further troubleshooting using below steps and share the ticket number here with us so we could escalate this issue:

  • Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button. If you get automatic reply, reply and indicate to it you need more help and reference to this topic
  • Or send an an e-mail to support[at]cloudflare[dot]com from your e-mail associated with your Cloudflare account

+1 good place to start.

Have them follow the instructions here https://developers.cloudflare.com/fundamentals/get-started/setup/account-setup/manage-account-members/

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.