Invalid SSL certificate while My site is SSL enabled from Lets Encrypt for 87 days now

I have transferred 3 days ago one of my websites vahuk dot com to a new VPS server with CyberPanel hosting control panel.

It was running well. Don’t I enable DNS proxy status to enable and then I am showing this error:
“Invalid SSL certificate Error code 526

Now when I disable the DNS proxy, the error remains to exist.

I have restarted my VPS a few times.

Any other solution PLEASE to fix the issue?

My SSL is issued by Lets Encrypt using the hosting control panel and is valid for more 89 days.

Well, After disabling the DNS proxy, My website is running well now. What should I do so that my website run well after the DNS proxy is enabled?

I presume you had your domain previously with another provider using Cloudflare.

If so → Troubleshooting Custom Hostnames / Cloudflare for SaaS when moving provider

I have not changed the domain provider and I have added the domain into Cloudflare long time ago. 3 days ago I just change the new vps server IP address.

Everything was well, just issue happened when TODAY a tried ti change the DNS proxy disabled into Enabled.

None of that was my question and it does not really address the link I posted either.

Follow through on the advice in that article and try to unblock all relevant hostnames as they are probably stuck with your previous service provider.

I believed, the problem is solved with the option: Liberate the Hostname from the above mentioned article.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.