Invalid name of certificate

dash-dns
dash-crypto
#1

I get an error warning people that the site may be attempting to steal their data. They are advised to leave the website. The error is Invalid name of certificate When I search further it says the cert is for a completely different domain. Any help is appreciated. Using the free SSL on shared hosting.

I setup cloudflare on sorajet.com whos IP address is 104.27.130.18
I get a warning saying the certificate is issued to bellacqualake.com at IP 108.163.224.69

CloudFlare SSL says issued to another domain
#2

Domain?

#4
#5

Loads fine for me

image

Probably a cached DNS entry on your end. Wait a bit until propagation is complete and any caches have expired.

2 Likes
#6

It also loads fine for me, and it looks like someone already successfully ran it through the Qualys SSL test.

I’d recommend you go to the Crypto settings page and enable “Always Use HTTPS” and “Automatic HTTPS Rewrites”

2 Likes
#7

Assuming your server IP ends in 69, it would appear another issue is there does not seem to be a valid certificate for your domain on your server and that your server does not even seem to be configured to serve your site via HTTPS.

You definitely need a certificate and should fix that configuration issue.

#8

It’s actually secured through cloudflare. If I also secured it with another authority it would become a real issue. I just turned off the SSL for today. Thanks anyway.

#9

Thanks. I did that and it didn’t help. I turned off the SSL for now. I just need to know why my browsers say the certificate is used by a completely different domain. Thanks for your help.

#10

Now it’s looking like you set HSTS, but without SSL, customers won’t be able to return-visit until you get HTTPS up and running again.

#11

This server couldn’t prove that it’s www.sorajet.com; its security certificate is from bellacqualake.com

1 Like
#12

It passes Qualys fine but the browsers say the cert is owned by bellacqualake.com, not the sorajet.com I’m working with. For now I stopped Cloudflare from caching the url so my site came back. Can’t think of what is causing this.

#13

That’s an issue at the server, since you’re currently bypassing Cloudflare.

#14

I know that’s the problem. Do you have any idea what I can do to solve it?
I setup cloudflare on sorajet.com whos IP address is 104.27.130.18
I get a warning saying the certificate is issued to bellacqualake.com at IP 108.163.224.69

#15

Who’s the web host?

  • If they offer free SSL certificates, ask for that.
  • If they let you upload your own cert, try the Cloudflare Origin CA cert.
  • If all else fails, you can use Full (Not strict) SSL here and it will accept that bellacqualake cert. But that’s risky because 1) It’s not your cert and that situation may change, and 2) It’s not a legitimate cert for your domain.
#16

It is not, you need a certificate on your server.

#17

Thanks for your help but I have over 50 accounts that are working just fine. It has nothing to do with a cert on my server. I’m using the SSL through Cloudflare. It has to be a Cloudflare issue. They control the DNS and they activated the SSL cert. It passes all tests on https://www.ssllabs.com/ssltest/
It has nothing to do with having a cert on my server. Like I’ve said It’s worked for over 50 domains on the same server. Thanks anyway. Dave…

#18

You dont seem to have one and that is an issue. Your site can never be secure that way.

For the third time, that is not enough, you need a certificate on your server too.

#19

Thanks anyway but that’s not the issue. I’m going to cancel with Cloudflare and open a new account and see if it works this time. Like I’ve said It’s worked with over 50 domains on the same server so I don’t know why this one domain needs something that all of the others don’t. I really do appreciate your help even though were not getting to the answer. Thanks again.

1 Like
#20

I understand that you have 50 sites, but these might be just as unsecure as this one. As long as you dont have a certificate for that site (or the 50 others) it wont be secure.

My point being, you need to make sure your connection is properly encrypted. Once that step is verified we can tackle any other issues that might have still remained.

#21

If you’re using Full or Full (Strict) the proper certificate appears to be installed, now.