Invalid Login Session for our corporate email addresses

I’ve configured an internal resource to be accessible externally using Access. The Access group is configured to only allow specific email addresses. Recently our corporate domain email addresses can receive the OTP code, but after entering the code users receive Invalid Login Session. I’ve cleared cached and tried incognito/private mode with the same result.

While testing I added my personal domain email addresses and can successfully login every time from the same computer/browser that was denied for our corporate email domain.

Any thoughts as to why only our internal domain would receive the Invalid Session Login.

One other thing to note, if I intentionally enter an incorrect pin for our internal domain we immediately see the Invalid Login Session. However if I enter an incorrect pin for the additional email addresses we receive - That account does not have access. It seems somehow our corporate domain is completey blocked for some reason.