Invalid Domain

I’m not sure what could be the problem, I’ve had no problem adding a site in the past.

Now when choosing to add www.springfield-ohio-post.com it states INVALID DOMAIN
So I tried taking the www off to make it springfield-ohio-post.com but it states INVALID DOMAIN
then I tried to put the www back on and add an http to create http://www.springfield-ohio-post.com but cloudflare’s response is INVALID DOMAIN.

I’ve been called worse.

So then I went and clicked a different link to add a domain (the upper-right one) and when I entered www.springfield-ohio-post.com it returned with something about making sure I’ve entered the root domain.
so then I took the www back off and resubmitted and this time it worked~!

But now I’m wondering if something else is wrong (for instance, if cloudlflare knows that springfield-ohio-post.com is the root and not what I thought was my preferred method of adding the www…

Oh man

Hi @springfieldcomputer,

I have just tested this and if you just put springfield-ohio-post.com, then it works for me. You can’t add www or any other subdomain, only the root domain.

Edit: Just saw your edit and that is works for you now.

I suspect maybe a rogue space at the beginning or end?

Not 100% on what you mean here, can you please explain?