Internal Server Error 503 The server is too busy to handle your request. Please wait a few minutes and try again

Hi I am using cpanel with engintron and have correct config for cloudflare but sometimes I get this message when I reload the page:

Internal Server Error

503

The server is too busy to handle your request. Please wait a few minutes and try again.

It goes away if I reload the page again but then it comes back etc

then sometimes pages become like this

sometimes they are normal

I also have a feeling that maybe there is something wrong with the default configuration? Maybe there is a limit set on how many requests a single user can make in a second or so

If you have any sort of rate limiting or security software, you should make sure you whitelist Cloudflare’s IP ranges: https://cloudflare.com/ips as well as restore visitor IPs.

1 Like

I just checked and this is already included

Surely you should have access and be able to review the error logs in apache/nginx as well as PHP and cPanel. Check those and see if any of them show why the 503 error is happening sometimes.

1 Like

Yeah that was the the first thing I did. I can not find the php log but other than that they are all empty

The php log would probably be it, but if you’re using Apache IIRC the PHP error log is a part of the Apache error log.

Is the cpanel server on a separate subdomain/domain? If so, it may be worth it to temporarily disable the proxy (click the :orange: to turn to :grey:) on that single subdomain to see if CF is the cause.

1 Like

I just tried to access it via the direct IP and it works just fine then. No random 503s

nvm. This seems to be a default cpanel error. I did a clean installation and the same error occured

This topic was automatically closed after 14 days. New replies are no longer allowed.