Intern assignment `git push` error: remote unpack failed

I’ve taken the Cloudflare New Grad and Intern Hiring Assignment
and due to the hiring email

When finished, you can submit by pushing your code:
git add --all
git commit -m “done”
git push

but when I ran git push this error occurred:

error: remote unpack failed: unable to create temporary object directory
To http://[path]/general.git
! [remote rejected] master → master (unpacker error)
error: failed to push some refs to ‘http://[path]/general.git’

This is not the place to go for the technical challenges. This is a forum for Cloudflare Products.

2 Likes

I know but there is not any email for a specific department or even a general contact email for such a big company as Cloadflare, so where exactly should I follow up the issue?!

I’m not clear how a git push error is caused by Cloudflare.

@moehmeni I am facing the same issue too. Did you find any way to connect with the hiring team?
About 3-4 days ago I submitted a general assignment and it was working fine, but now I am getting the same error while pushing to systems repo. I believe the remote server hosting this git repos has run out of space and due to holidays, CF hiring team might have missed this. I hope they fix this asap.

@sdayman These are git repos hosted by CF for their Inter hiring assignment. They might have run out of space or changed permissions recently which is causing this git push error.

2 Likes

@user16157 No, I didn’t find a solution yet and also have posted the issue in the internship community which was mentioned in the blog article.

1 Like