Intermittent error

Follow up, for me, this is looking like an 70% GoDaddy, 30% Cloudflare issue.

First, the IP issue solved site 1. Not sure how a site can have multiple IPs on a GoDaddy server but hey, worth checking out if you’ve moved, restaged, something one of the sites.

Second, on site 2, turning on WP debugging revealed a number, 3-5, of PHP/WordPress deprecation warnings. Again, warnings not errors. (And not PHP warnings but WordPress function deprecated warnings.) What’s more, these only showed in the admin. That said, I patched the older plugin, and turned off SSL and the site is back up. (Cloudflare SSL is giving me errors for the moment.)

The errors from the plugin occasionally stopped WordPress from fully loading the administration which is what tripped up Cloudflare. What doesn’t make sense is, I could not get these errors/warnings to show on the frontend and, without explicit errors on, these didn’t even show before at all, anywhere. My guess is an error was in one of the headers sent from GoDaddy to Cloudflare and Cloudflare read this as the site is down, not just errored.

GoDaddy is mishandling PHP Warnings, Cloudflare is considering 1 error header as the page is “down.” Hopefully that helps someone.

Edit: Word.

Did you turn off ssl or pause the site in Cloudflare? Pausing the site seems to help a little.

I think if we called GoDaddy and begged them to change the IP on our website that it would fix the issue. I’d bet $1 on it.

Paused Cloudflare, sorry that phrasing is ambiguous. It does help but isn’t really a fix.

I checked a number of sites for @whitney, @nima.asghari, @itamaram @nicholas.harvey.pers and generally cannot see the errors, but let us know if you are still seeing issues, (if you have a ticket with support, they’ll follow-up).

@djoaquing, no, it’s not Cloudflare blocking godaddy. We did have an issue a few weeks ago where godaddy was blocking some Cloudflare IPs, but unrelated to these issues. A couple of questions - if you have a certificate on your origin server, on the SSL/TLS app, can you set SSL to Full (Strict)? And, it seems the behavior of www.domain.com is different than domain.com, can you check the value of your www DNS record?

I ‘paused’ 2 out of 3 sites that was causing the problem.

The third site [email protected] said was working, but it’s still down.

I love you guys and want to make this work, but I can’t think that all of us having the same exsct issue at the same exact time with the same exact product at the same exact vendor is mere coincidence.

You are welcome to go thorough the logs or unpause any of my sites. You should see them going up and down.

@cloonan The issue was definitely still happening on one of my sites, even a 5 minute interval checking got more than a few 520s. But just switched the hosting from GoDaddy to Dreamhost. (Not that I recommend Dreamhost, this is a patch, there something wrong with how the PHP is being executed on that server and there’s no error logging to go off of.)

@djoaquing Easy Columns. It hasn’t been updated in years so glad to get rid of it but something else was still resending headers and causing the interrupts. Again, this is 70-30, 80-20ish, GoDaddy and Cloudflare respectively. There is definitely a problem with the site on the server but why it triggers a full 520 is a little odd. (As in the page should still load, though header resending is definitely bad.) Not sure what to make of your errors exactly, the only thing that seems odd is the 301, as though the .css moved and it could be redirecting.

@nicholas.harvey.pers Having now switched the second of the 2 sites with issues (that’s now running fine on another L 2.4 A M 7.2 P stack), I’m pretty sure this is an odd confluence of issues that is hard for them to diagnose. To me, GoDaddy are the bad ones at the moment. Clearly there are problems with the sites/servers that aren’t being exposed so we can take care of them. That Cloudflare is just blindly 520ing the errors isn’t helpful but technically they aren’t causing the problem in the first place.

Also a sample of the intermittent PHP error I was getting. Doesn’t occur on local LAMP or Dreamhost LAMP, just GoDaddy. Now that the server isn’t live, will be walking this through with them… Slowly.

Warning: Cannot modify header information - headers already sent by (output started at wp-includes/functions.php:3853) in /home/content/wp-includes/pluggable.php on line 1219

Edit: This is WP core doing this, I believe all plugins were disabled by this point.

Ok, thanks. I’m on an “estimated 18 minute” on hold with Godaddy about threedistinctknocks.org. What should I ask them?

I’m late to the party. In the past I’ve found 52x errors to be attributed to an overactive firewall at the ISP. When it sees a lot of traffic from a single IP (like Cloudflare’s) it will start spitting back 52x errors. I’ve also seen this on sites without Cloudflare, when google would index a site, it will report 52x errors as well.

@nicholas.harvey.pers So it’s showing the same issue, 520 then, on reload, loading fine. If they can output any PHP errors, warnings, notices, all seem to be relevant.

The tech I got disabled plugins by renaming the plugins folder so make sure they don’t do that (probably not an actual “tech.”)

@jules Makes a good point and you can ask if they are blocking/flagging IPs but there’s not a way to confirm that. Some of the managed WordPress allow SSH but I doubt the IP tables are readable (or definitive.)

Also see:

A few resolutions:

  • Wait for CF’s cache to fill. Then requests to the origin will decrease and the firewall will relax.
  • Get a better host. Have them whitelist all of Cloudflare’s IPs.

On the phone with them now. Super nice guy, he’s “bringing it upstairs” because there’s only so much they can do…
If we bypass Cloudflare, the site works fine. So I totally get if they come back and tell us it’s up to Cloudflare.

Update from GoDaddy: they notified (whoever) on the GoDaddy side and gave a heads up about the issue. Apparently it’s still a small enough batch that they’re not sounding the alarm -yet-, but they promised to continue monitoring the situation.

They were reading this thread, so at least we have more eyes on it.

That will make the problem last longer. Let caches fill so that the origin (and the firewall) is not hit so much. Then the 52x errors should go away.

Waiting for the cache to fill might help if it is a firewall issue but for me it was a PHP execution issue, no amount of waiting was going to stop the errors. (The site was going up and down for a full day, no doubt fully cached at some points.)

That said, if bypassing CF does fix it here, it seems more likely it’s a Firewall related issue. There are definitely multiple issues causing the same error.

Throwing my hat in the ring here. Having the same issue and it just occurred in the past couple days. I will allow the cache to fill and see if it mitigates the problem.

@user9721 , @djoaquing - As of this moment, the only working band-aid is to “pause” the site in Cloudflare.

Same problem here. I have ten sites with Managed Wordpress (GoDaddy) and Cloudflare was working fine for three or four months. Now I get 520 errors just like the rest of you.

GoDaddy does not offer any help (to me) As far as they’re concerned it’s a Cloudflare problem.

1 Like

Does pausing it cause us to lose SSL causing our site to show up as not secure on google chrome?

Same exact problem. I’m beginning to think it doesn’t behoove Godaddy to actually fix the issue as using free SSL with Cloudflare doesn’t exactly help them sell SSL certificates to us through Godaddy. Or maybe I’m just too skeptical.
:man_shrugging: