Intermittent Error 520, host says nothing in logs, Always Online off

Same problem here as well

Exactly the same problem here as rdmegna describes. These problems started a week ago without any changes made on the website/server

We have been using cloudflare for years, and with no problems.

but since a few days, we started getting 520 errors randomly all day.

we had to disable and say goodbye to cloudflare, to avoid these cloudflare error.

Its not an origin-server error, it’s a cloudflare error.

thanks.

1 Like

I created a ticket but was marked as solved automatically :confused:
Ticket Number: 2246321
@MoreHelp Could you please help us with that, these errors started a few days ago (I saw the first error on Aug 27, 2021).

Thanks,

Ah I started a new topic with the very question, now I see there are lots of posts.

Yes, exact same situation here, random 520 errors started a week (?) ago, no changes on the server.

It is infuriating because I am locked to CloudFlare, as we use them for HTTPS.

Then you currently have a security issue.

Actually Sandro, I’m in a similar situation as user6617, and it’s not a security issue that I know of: We use the CloudFlare origin SSL certificate instead of our own, but we’re on Full Strict just the same. CF recommended we use their origin certificate to rule out problems with our DigiCert certificate and it works well so we kept it and cancelled our DigiCert.

Now though, to turn off CloudFlare, we’d need to get a new SSL certificate…

That’s a secure setup and not what I was referring to. The posting I quoted appears to say that the user has an insecure mode on Cloudflare and no encryption on his server and that is aforementioned security issue.

Yes, the error is intermitent if you are facing the error temporary solution is to Pause the site from the Cloudflare Dashboard, if you have a SSL from Cloudflare you can switch to free Let’s Encrypt certificate till the problem is solved !!

The 520 error is occuring in a abnormal way, it not happening because the Cloudflare didn’t reach the Origin server but its happening becuase it’s facing issues from the core of the Cloudflare. I don’t know how Cloudflare works in such cases but i guess the more complains will lead to some solution so here’s my input. I can provide further details if MVP’s or any technicians wants some insight.

I have default Cloudflare settings with no Cloudflare SSL and with Full (Strict) option enabled !!

Logs are clear, started to appear from this week and did some stupid things with the server like restarting, renewing the SSL, pinging the server, added alerts and monitors but the issue is not from the server but the Cloudflare itself.

1 Like

Going through the same problem here. The error started two or three days ago, I don’t know, and I didn’t make any changes to the server at all. I live in Brazil, in São Paulo.

The error comes up occasionally, and just refresh the page for everything to go back to normal.

Same issue here with digitalocean droplet.

Same issue here

Hi all,

Due to the number of 520s being reported in similar circumstances, we are escalating the issue to Cloudflare Support. The original incident should have been resolved and your issue may well be unrelated.

We recommend checking these troubleshooting tips, if you haven’t already.

https://support.cloudflare.com/hc/en-us/articles/115003011431-Troubleshooting-Cloudflare-5XX-errors#520error

If you have been through these thoroughly and are not seeing corresponding issues on your network/server and you have a ticket number with Cloudflare, please reply and post that #.

To enable efficient troubleshooting by support, please ensure you include the following on the ticket:

  • example URL(s) where you are seeing the error
  • Ray IDs from the 520 pages
  • output from a traceroute from any impacted user
  • output of example.com/cdn-cgi/trace - replace example.com with the affected domain.
  • Also include two HAR file(s) : one detailing your request with Cloudflare enabled on your website and the other with Cloudflare temporarily disabled - see How do I temporarily deactivate Cloudflare ?
3 Likes

Same issue here. Started 10 days ago.
It just happend again, 20 minutes ago:
Ray ID: 68a3406d1821f633 • 2021-09-05 23:31:32 UTC

Open a ticket with the details, as stated above, and post the number here.

Same issue for me here with multiple Error 520’s, since around 10pm on the 4th September. Pausing Cloudflare on the site makes the problem go away, but when it’s Enabled the problem is intermittent using Chrome or Edge including Incognito/InPrivate, and from multiple locations and devices.

Logged a call, ticket #2248941, but as I’m on a free plan I don’t have support.

Thanks @matteo for scaling the issue, just to let you know, I could reduce (but not eliminate) the 520 errors disabling keep-alive in my server. Now I close the connection to CF after each request that I receive.

I’m using HAProxy 2.4.3 + nodejs 14.17.6 (both latest versions today) and my server is located on AWS, region: us-east-1

1 Like

Same issue here: Ray ID: 68a8d5859e0ed2b8 • 2021-09-06 15:47:08 UTC

Same issue with our website. It was working without these errors before. Nothing has been changes on the server side.

One of the Ray ID: 687779ecfeeb005b

Having the same issue. My case ID:2250694