Intermittent 503 errors

We are receiving 503 errors on our staging and production environments.

At first we thought this was due to a large number of connections from the same origin (a lot of connections are devices with sim cards), so we added bypass rules for rate limiting and “Essentially Off” marked out DDoS settings.

503 errors are still happening (see full response below). We noticed that about 18 hours ago an outage happened relating to intermittent 503 errors: Cloudflare Status.

It’s marked as solved but we suspect it is not solved yet for us or our regions.

Note: we are also trying to upgrade our account to increase the amount of monitoring and tools but there is a billing error (Code: 1292) we receive and no one is contacting us to resolve it. Can someone help us spend money on you??

t07:11:46:RECEIVED [HTTP/1.1 503 Service Temporarily Unavailable
Date: Wed, 27 Oct 2021 07:13:44 GMT
Content-Type: text/html; charset=UTF-8
Transfer-Encoding: chunked
Connection: keep-alive
X-Frame-Options: SAMEORIGIN
Referrer-Policy: same-origin
Cache-Control: private, max-age=0, no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Expires: Thu, 01 Jan 1970 00:00:01 GMT
CF-RAY: 6a4a1f9f49142056-AMS
Server: cloudflare
da0
<!DOCTYPE html>
<!--[if lt IE 7]> <html class="no-js ie6 oldie" lang=]
07:11:46:WS KEY ERROR
07:11:47:KWH:AD[1]RG[8900]REC[221,221]ERR[TO]
07:11:47:RECEIVED ["en-US"> <![endif]-->
<!--[if IE 7]>  <html class="no-js ie7 oldie" lang="en-US"> <![endif]-->
<!--[if IE 8]>  <html class="no-js ie8 oldie" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
<title>Rate Limited</title>
<meta charset="UTF-8" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=    ]
07:11:50:WS KEY ERROR
07:11:51:RECEIVED [  <p>Too many requests for X. Try again later.</p>1" />

What is the domain?

Unfortunately I cannot actually type the domain because of some forum restriction, so I will attempt with a space in between:

Subdomain: ocpp.e-fl ux.nl
Domain: e-fl ux.nl

Your subdomain has 2 issues

  1. Site does not support https

  2. 524 a timeout occured error

Your root domain loads normally

So how do I generate the 503 error on my end?

It is a websocket only endpoint at a specific path. The root will not respond. There is one normal HTTP endpoint you can hit to test which loads fine via HTTPs:

https://ocpp.e-fl ux.nl/status

We are seeing 503 errors only from a specific origin IP range at the moment and they are intermittent. These happen when new websockets are being established.

So some users get the error but not all?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.