Intermittent 400 errors after hitting upload limit

We have one user who uploads a lot of images to our admin site, and recently he accidentally tried to upload an image that was larger than our upload limit of 100 MB. Since then, he has been seeing intermittent “400 Bad Request cloudflare” errors when trying to upload images – even when his upload requests are far less than the 100 MB limit. These responses appear to come back pretty much instantly, which, along with the explicit “cloudflare” on the error page, leads me to believe that in these cases his requests are erroring out at Cloudflare and not even getting passed to our servers.

Is there some sort of user blocking that occurs after someone hits an upload limit, or could there be some sort of caching of 400 errors here? I am at a loss for what to try next to resolve this for him. It’s probably worth noting that this user generally uses Safari on macOS; when trying similar uploads in Chrome, he does not see any of these intermittent 400 errors.

Not to my knowledge. Can you reproduce it?

Also, it would mean there should be some connection between your and/or Cloudflare’s sessions. Overall, I’d say it is rather unlikely that this is something Cloudflare related.

Do you find the 400s in your server log?

Maybe something cached by Safari? Did he try clearing the cache?

There are no 400s for this endpoint in our server log, and this user has tried clearing all his browser data (cache, cookies, etc) for our site but still sees this error periodically.

It probably is best to open a support ticket in this case.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.