Integration with W3 Total Cache

Hopefully somebody can shed some light for me.I have been following along with a guide (https://www.mprstudio.com/speed-up-wordpress-w3-total-cache-Cloudflare/#comment-2688) for setting up Cloudflare and W3 Total Cache, however i cannot seem to complete it due to a recurring Cloudflare not available: Failed to reach API endpoint message. I have looked around and tried everything i could find, but to no avail. As i am an absolute novice, i thought i may be able to get some ideas here. Can anyone help?

That’s a long article, but I don’t see anything in there about entering your Global API key. I suspect it’s in that “Reauthorize” button or whatever it’s called the first time around.

So…did you enter an API key and your email address?

Thanks for the reply

I did enter it. Copied and pasted straight across. When that didn’t work i changed the Global API key and changed again. Still no final connection. Email has been checked and double checked too

1 Like

If you have command-line access to your server, try this ‘curl’ command using your credentials (Email and Key). This should let us know if you can reach the API endpoint from your server. Or maybe provide a more detailed error message.

curl -X GET "https://api.cloudflare.com/client/v4/user" \
     -H "X-Auth-Email: [email protected]" \
     -H "X-Auth-Key: c2547eb745079dac9320b638f5e225cf483cc5cfdda41" \
     -H "Content-Type: application/json"

This topic was automatically closed after 14 days. New replies are no longer allowed.