Installed SSL certificate is invalid

Hi, I have installed SSL on Godaddy
Certificate ID: Cloudflare_Origin_Certificate_df951_b82d5_2187435660_80f5bd0742380178f0d6216536ab6c9c

but I get this error message in Chrome “SSL certificate is invalid” It also doesn’t work in firefox)

DNS is proxied.
Enabled: Your SSL/TLS encryption mode is Full (strict)

I don’t get any errors on

The certificate should be trusted by all major web browsers (all the correct intermediate certificates are installed).
The hostname is correctly listed in the certificate.

What could be wrong?

What is the domain?


“Peer’s Certificate issuer is not recognised.”

It may be slow DNS propagation to the resolver you are using. You only added the site to Cloudflare a few hours ago…
…so maybe some requests are still going direct to your server and not through Cloudflare.

The Cloudflare origin certificate is only trusted by Cloudflare so those direct-to-origin requests will show a warning until the change reaches your DNS resolver…

It should start working for you soon. It works ok for me on Safari, Chrome and Firefox.

1 Like

Thank you for replying. It’s been almost 24 hours and it’s still says “connection not secure”.

Could it take more than 24 hours? What else could wrong?

Do you have any local DNS or host file settings that have hard-coded your website to the origin server IP address?

You can try nslookup at a Command prompt in Windows to see how it resolves at your end, or dig on Mac or Linux.

1 Like

Unfortunately, I’m not sure what “hard-coded to the origin server IP addess” means.

When you visit the website, do you see a lock? or does it say for eg “certificate not trusted”

I checked CHECK DNS PROPAGATION and the nameservers have changed to most nations. It did, however, say “may not have fully propagated across the internet yet.”

Of course, as I said your site was working…

Certificate details are here…

If you are not seeing the Cloudflare edge certificate shown here, then something local to your machine or network is returning the IP address of your origin server instead of Cloudflare’s proxy.

1 Like

Ok. Thank you very much.

I checked on an Ipad today and the lock was showing.
On my computer it’s still not showing on any browser.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.