Initial setup: Setting up NS to point to Cloudflare

I’m trying to set up a new domain to work with Cloudflare. The domain is: officer.feedback and I just purchased it from gandi 2-3 days ago.

By default, inside the gandi interface, my original nameservers were all at gandi dot net.

But when I used a dns checker, the results were different. They looked like this:
e dot nic dot feedback and caddilac dot net (several entries)

I changed my DNS setting in the gandi interface and they have been like this for two days:

However, when I keep checking the dns checker to see if the NS records have changed to Cloudflare (and also checking the Cloudflare interface), I see that my records have not changed.

I have a support request pending at gandi as of yesterday. They are telling me to wait longer before contacting them. I reached out again today and am still waiting to hear back. I did not create a cloudflare support ticket since they recommend using the community resources first.

My goal is to get my name servers pointed to cloudflare. I’m confused that my NS records as shown by the DNS checker don’t match the original gandi NS records or the cloudflare NS records.

I want to thank anyone who helps me ahead of time. This community owes me nothing, yet it helps - which I appreciate. I’m happy to provide any additional information / screenshots as needed. Also, this is my first post here. I did read the DNS FAQ and followed the steps but was not able to figure it out. Also, I’m sorry for spelling out domain names. I initially put in several screenshots. As a new user, this forum forced me to only use one screenshot. I then typed out the actual NS values. This forum interprets them as links and as a new user, only lets me use two. I couldn’t figure out how to put the actual NS values without them being converted to links and blocking this post from going up. So I had to spell them out.

I use Gandi for many of my domains, and that looks good to me. WHOIS at Gandi confirms the change.
Beth & Brad thinks Beth is authoritative for the domain.

I don’t see a DNSSEC problem, either.

It could very well take the full 48 hours for the name server change to take effect.

1 Like

Thank you. I’ll wait another day and see what happens. I think I can post more than one screenshot now.

This is what my original dns setting were before I changed them to cloudflare:

Here is what my dns checker is currently showing:

Any reason my NS dns values as shown by the dns checker differ from both my old (gandi) and new (cloudflare) values? I’d expect the current values to be one of the two.

Thanks again.

Very good question on why it’s clearly wrong. And it’s still not propagated. At this point, I suggest putting it back to Gandi’s LiveDNS servers. Wait 15 minutes, then set it back to Cloudflare. Changes should start showing up within 12 hours.

Or ask Gandi for help.

Thanks again. I replied to gandi to renew my request now that it’s been 48 hours. I’ll see if they reply by this evening. I would do the switch now, but I don’t want them to make me wait another 48 hours before giving me support. So I’ll try them first. If they don’t reply by this evening, I’ll switch my DNS back and forth and update this post with the results. Thanks for trying to help.

This is a unusual situation for me. I’ve set numerous domains to work with cloudflare in the past with no issue. I set the NS records to cloudflare as a test (from godaddy) and it propagated as expected in minutes. This gandi domain is obviously a much different story.

2 Likes

Here is my update on my officer.feedback domain:

So after not getting a gandi reply this evening, I switched to Live DNS. Just after switching to Live DNS, gandi replied and told me to change back to cloudflare’s nameservers and wait another 24 hours before contacting them again. I knew that was going to happen.

They provided no substantive help even though I provided them a link to this thread. And since their replies seem to take about three days, it will be about four days before they will help on their side. So, as suggested here and by gandi, I switched back to cloudflare nameserver in their interface. At this point, I’m going to see if they propagate this time. If they don’t (which is what I expect), I’ll wait for gandi to reply again or for another suggestion here.

All my DNS checks are still showing:

e.nic.feedback
ns1.cadillac.net
ns2.cadillac.net
ns3.cadillac.net

At no point have my DNS records propagated to show the gandi or cloudflare NS records.

Any other suggestions? Thanks again for the community help. I’m just bummed and frustrated that nothing seems to work. Below is gandi’s email to me and my most recent email to gandi.

Gandi:

Me:

Hi @dtrizzle,

whois shows the nameservers correctly,

Dates

  • Registry Expiration: 2022-08-20 23:59:59 UTC
  • Updated: 2020-08-24 07:35:12 UTC
  • Created: 2020-08-20 17:05:06 UTC

Your domain has several statuses in place, the clientTransferProhibited is expected if your domain is locked at your registrar and addPeriod is normal for newly registered domains. serverTransferProhibited is more unusual and I’m not sure if that would affect the nameserver change.

If we query the root nameservers, we see the ones that you get on your DNS lookups.

$ dig ns officer.feedback +trace

; <<>> DiG 9.16.1 <<>> ns officer.feedback +trace
;; global options: +cmd
.                       79727   IN      NS     m.root-servers.net.
.                       79727   IN      NS     b.root-servers.net.
.                       79727   IN      NS     c.root-servers.net.
.                       79727   IN      NS     d.root-servers.net.
.                       79727   IN      NS     e.root-servers.net.
.                       79727   IN      NS     f.root-servers.net.
.                       79727   IN      NS     g.root-servers.net.
.                       79727   IN      NS     h.root-servers.net.
.                       79727   IN      NS     a.root-servers.net.
.                       79727   IN      NS     i.root-servers.net.
.                       79727   IN      NS     j.root-servers.net.
.                       79727   IN      NS     k.root-servers.net.
.                       79727   IN      NS     l.root-servers.net.
.                       79727   IN      RRSIG  NS 8 0 518400 20200906050000 20200824040000 46594 . ekBVs0eBVNL97qe3Xim4ps+N9NQaQNcRjA7Y22cdkmVfhbYKYf7eYF+j tVvo8h5Fu1LkxsyBYkFk7G1g4vDq6WI8Pya/20UQpo2nHEuQskdV2W5E Qw6JioPbWeCuMbaBe8aN/kCX+ItZPsaEHmHuiUFRyyLNp1i6u7BYHL4C v7UJJI5pFArSEDc/6DoVTJiyulN2cSinK+riQNWAW9HzuqGDnMt9MNQJ B2xAmygkcS4jTuOnfW+/3b7fRPpZyHCcKHDHRULcFjwGSo45SW66O/bn S/RsxR4f3lqu9xShzDD+PO07NegouYYCjhyl94ZaiVZJIrHFMXpBraxs 5AokTw==
;; Received 525 bytes from 8.8.8.8#53(8.8.8.8) in 30 ms

feedback.               172800  IN      NS     a.nic.feedback.
feedback.               172800  IN      NS     b.nic.feedback.
feedback.               172800  IN      NS     c.nic.feedback.
feedback.               172800  IN      NS     d.nic.feedback.
feedback.               86400   IN      DS     16786 8 2 00F7F4B6DF67DC7B828C14829884908EE92E57FE312ED483C43DA299 FA5DDAE5
feedback.               86400   IN      RRSIG  DS 8 1 86400 20200906050000 20200824040000 46594 . KUP1wrlyegzo7RXx82tZP0q1DLwaxIPn22gaxNueCorFJs7cpeA3/eJF w6Ng0w1VI3hSau9EBFIrWz46LBuw70Tq2ppCrj3ihrSDtm66hpOfDQd7 PF4PZNI1AssEMpmm2PMRRcXBoHQXwkhp9uQqQn9ZU2BLr6Vfo3hvkms6 31GB05Ox+s4/zZAvG93dQ7ZhFx/z7uIJXd1QEmOX+1l3m/JEgzc/mBYk 5WLaHULdp1ZOErjW3H5Mvp+KLVhE7kPpC4C8BaxAh0liK1OuqCvpquUa 1WMshnMv4iEqzhc3rM+X+HoZw1VCu6QyCGfMhJJ3+gPd6bd4JCwOScy2 +5ByBA==
;; Received 624 bytes from 192.5.5.241#53(f.root-servers.net) in 13 ms

officer.feedback.       3600    IN      NS     e.nic.feedback.
officer.feedback.       3600    IN      NS     f.nic.feedback.
2n8tkjumbgapsmlite2qlku0f1dg6gup.feedback. 3600IN NSEC3 1 1 1 - 2N8TKJUMBGAPSMLITE2QLKU0F1DG6GUP NS SOA RRSIG DNSKEY NSEC3PARAM
2n8tkjumbgapsmlite2qlku0f1dg6gup.feedback. 3600IN RRSIG NSEC3 8 2 3600 20200901070354 20200802004927 60385 feedback. PWlll7NlhrWxYaJYOqgCNlPdx+VL3DXmOhD9iX0iRAO1QC7kA+bFyRbh wsG+5ZWBbpYbRHe/iqdlD9hAf+TMt0Oaoz8rvvILle6yCoHWrEcRXB3v Mv12j3txdPNORVynH7BALO0sm0LAabsgW2Kwg9U2xTAZxGHkbfF3RxXi phE=
;; Received 329 bytes from 185.24.64.50#53(b.nic.feedback) in 60 ms

officer.feedback.       14400   IN      NS     ns1.cadillac.net.
officer.feedback.       14400   IN      NS     ns2.cadillac.net.
officer.feedback.       14400   IN      NS     ns3.cadillac.net.
officer.feedback.       14400   IN      NS     e.nic.feedback.
;; Received 344 bytes from 192.48.85.146#53(f.nic.feedback) in 170 ms

I’m afraid that I think this is an issue that only your registrar can help with. That’s really annoying if they keep making you want after changing anything, though!

1 Like

Thank you for the additional information domjh. I looked up the serverTransferProhibited status and learned the following:

This status code prevents your domain from being transferred from your current registrar to another. It is an uncommon status that is usually enacted during legal or other disputes, at your request, or when a redemptionPeriod status is in place.

I wouldn’t think it would affect NS propagation, but who knows. Also, I have no disputes as I just purchased the domain days ago. A few minutes ago, gandi elevated my support request to their “specialized team”.

Annotation 2020-08-24 225207

I’m hoping for the best. Thanks again for everyone’s help. I will continue to update this thread until the problem is solved or I give up (in which case, I will say so). I never knew getting nameservers to propagate could be so difficult.

1 Like