InfinityFree with CloudFlare end-to-end-encryption

Hello! I´m trying to implement Full mode Encryption for
Can you help me understand why when I use https the browser respond with ERR_SSL_PROTOCOL_ERROR and still working with http?
What’s missing in the configuration?
Many thanks in advance.

That should be “Full strict”, if you want a properly secure encrypted connection.

The issue in your case is that your webserver does not seem to be properly configured for HTTPS. You’d need to talk to your host about that.

Overall, you should generally contact your host as your domain’s DNS configuration seems to be very off.

It returns for every query a CNAME pointing to That means, for example, email will never work.

Many thanks for answer @sandro. The ideal will be Full Strict and I set it up, but when I upload the CloudFlare created certificate in the origin server …

I get:

Like the certificate is for CloudFlare and not for my domain.
What I’m doing wrong?

You best contact your host about that. Maybe it would be best to disable the partner integration and set up a full Cloudflare account. Your current DNS configuration on your host’s side is broken anyhow.

The error message here will be because the certificate wont’t contain the domains in the CN but only in the SANs, but there is perfectly okay and something your host needs to fix too.

For the moment and as I can’t use this certificate, until this issue is fixed, I decided go back to the Flexible option and don’t ask me why but https begins to work. Maybe it was only question of time.

You shouldnt use Flexible, as that just leaves the impression of actually encrypting something when it actually offers no encryption whatsoever.

You should really talk to your host about that.

This topic was automatically closed after 30 days. New replies are no longer allowed.