Infinite Verification Loop on mobile browsers for

Answer these questions to help the Community help you get started.

What is the domain name? But the loop only occurs whenever attempting to read any stories on the site itself. I can access the rest of the site and search stories, I cannot read them however on the Samsung Internet Browser for my android phone, as well as the Chrome mobile browser.

Have you searched for an answer?
Yes, most posts have directed me to clear my cache and cookies, use an alternate browser, use incognito mode, scan for malware, and disable adblockers. None have worked.

Please share your search results url:

When you tested your domain, what were the results?
Whenever I attempt to access a story on, it is stuck in an infinite loop where it tries to load up the verification box. However this box only appears for a split second before disappearing again, making it impossible for me to verify.

Describe the issue you are having:
Whenever I attempt to access a story on, it is stuck in an infinite loop where it tries to load up the verification box. However this box only appears for a split second before disappearing again, making it impossible for me to verify.

What error message or number are you receiving?
No error message or number has been seen, but the tab is renamed to “Just a Moment”.

What steps have you taken to resolve the issue?

  1. Clear cache and cookies
  2. Use the Chrome mobile browser
  3. Use incognito mode
    4: Disabled adblockers
    5: Scanned for malware

Was the site working with SSL prior to adding it to Cloudflare?
I believe so.

What are the steps to reproduce the error:

  1. Attempting to read any story on

Have you tried from another browser and/or incognito mode?
Yes. I have attempted to use the Chrome mobile browser as well as incognito mode for both browsers.

1 Like

I’m having almost the exact same issue on on my samsung phone with android 11, starting from 13th July 2023 morning.
(But fanfiction. net doesn’t give a loop on me, it proceeds after I tick the box. So I can see the comics on it in both Chrome and Opera.)

Noticed it on Opera’s VPN (vpn location was asia) (the site is banned in my country so I have no other choice than using vpn). I can check the boxes but it just keeps reloading. Checked the boxes about 10 times then gave up. I already uploaded opera’s latest version, adblockers disabled, cache already cleaned, tried in Opera’s incognito & vpn too (still gives the same loop and I can’t even reach any comics in it). Same with cellular and wifi too.

I wondered if it’s my opera vpn that causes the problem; then I also turned my wifi off and on (no change), downloaded opera on my samsung tablet and tried to access from there (it went into loop there too just from the first try), lastly I heard of cloudflare’s own warp app and downloaded it on my phone, to just give chrome &warp a try. Still didn’t work and put me on a verifying loop on Chrome…
Also downloaded Aloha browser too (because it had built -in vpn) to try if its vpn work, but no. But the cloudflare verification button during Aloha browser gave me an interesting additional text: It says “failure” right before reloading.

I joined Cloudflare to solve this problem today. And there doesn’t seem any solution given for years, except “delete your cache and cookies/update things/disable adblock and disable Do not track/" things. But I wanted to report this same type of issue here too.
(Cloudflare saw me %93 human, when I opened vpn it saw me %89 human. I don’t know if these percentages are even useful though…)

(please forgive as I want to make a little addition but I don’t see an edit button i think I have to reply to myself. A way to enter to myreadingmanga. info site after 3 hours, I hope it works for fanfiction. net too which was already working for me)

(By the way this is the “Failure!” text inside the box coming up and looping in Aloha browser. But other browser didn’t have the failure text, otherwise same loop. (Gif proof:
SmartSelect_20230714-052024_Internal Audio Recorder

I kept searching for this infinite loop problem and I’m not tech savvy but I saw a github user guessing like “it’s maybe because chromium-based browsers cause infinite loops”.
I learned Aloha browser is “webkit-based”, I don’t know how much difference it has with chromium but I’d guess it is similar because it gives the same loop too (also a couple of manga reading and a cooking recipe site too which blocked my ip. Loop in Opera&opera’s vpn, Aloha and Chrome both with Cloudflare’s Warp 1⁴ app too. Not all but definitely more than 1 website)

So since firefox is not chromium based, I opened firefox with Cloudflare’s Warp 1⁴ app open. It really proceeded to myreadingmanga with only 1 verification box and opened the comics. (It opened the recipe sites which banned my ip through cloudflare without issue too, and opened some adult manga sites like nhentai .net (which are all banned in my country, thus need something like vpn) open without issue too but the images on it won’t load.

TL;DR Since firefox is not chromium based I opened firefox as Cloudflare’s Warp 1⁴ app is open on my phone(samsung android 11).
(Not saying like if any other vpn/warp wouldn’t work, but that I had 1⁴ at hand now so I used it.)
(Issue on other browsers I mentioned still continues so this is like a workaround instead of a solution.) Firefox proceeded to myreadingmanga with just 1 verification box, no loop, and opened the comics, all images visible.
I already can reach fanfiction. net but I had the same issue with myreadingmanga (and a couple of websites) I am sorry for this very long comment. I hope firefox works for you too

1 Like

I took your advice about using something other than a chromium-based browser app and installed the Firefox browser app. That seems to have fixed everything as I can now access the website, thank you.

1 Like