Infinite "Checking if the site connection is secure" Firefox loop despite check boxes verifying my humanity; works in Chrome

Complete this information in order to ask your question.

Have you searched for an answer?

Yes, I looked at over 10 similar questions and I don’t think their comments apply (details below).

Please share your search results url:

I am trying to access help goodeggs com (I cannot use a link in this post apparently)

When you tested your domain using the [Cloudflare Diagnostic Center], what were the results?

N/A, I’m an end-user.

Describe the issue you are having:

I have had persistent issues with infinite loop challenges with Cloudflare both with various Science websites and now just trying to access an eggs website. I answer the challenges and I get a checkbox but it just comes back to another challenge. The errors are either “Checking if the site connection is secure” or “needs to review the security of your connection before proceeding”.

The problem does not happen on Chrome. The problem happens on Firefox version 110 on Fedora Linux 37. I am not running any Firefox modifications, ad-blockers, or other extensions. I am in Texas in the United States and I do not use a VPN. My internet provider is AT&T. Normally, I just access the pages in Chrome as a workaround, but the annoyance has exceeded my threshold.

I have a HAR file but the attachment button only supports jpg, jpeg, png, gif, heic, heif, and webp. I have uploaded an encrypted zip with the HAR file to GitHub.

However, I cannot add a link with the error message, “An error occurred: Sorry, you can’t include links in your post. To share a link, click the pre-formatted text option which will add back ticks characters to the url. backtick example

This error message doesn’t make much sense as I tried both using the link button and backticks but always get the error. The file is under the kevgrig/CloudFlareIssues repository on GitHub.

I can provide the password over direct message.

What error message or number are you receiving?

  • “Checking if the site connection is secure”
  • “needs to review the security of your connection before proceeding”

What steps have you taken to resolve the issue?

Used Chrome as a workaround

What is the domain name?

For example, help goodeggs com

Was the site working with SSL prior to adding it to Cloudflare?


What are the steps to reproduce the error:

Access various website in vanilla Firefox version 110.

Have you tried from another browser and/or incognito mode?

Works in Firefox Incognito Mode or Google Chrome.

Please attach a screenshot of the error:


Additional notes: Since Firefox incognito mode works, it’s presumably some sort of cookie that Cloudflare cannot interpret properly; however, I just tried clearing Cloudflare cookies and refreshed and still see the same issue. Also, I’m not using a VPN.

I don’t think I should need to clear all cookies in my entire browser. If you have some specific domains to clear, I will try that.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.