Infinite 301 redirects out of nowhere

Out of nowhere my site started 301 redirecting to itself. I haven’t touched my settings in a long time and my site has worked without issue for years. I noticed a couple of hours ago that there was now a 301 redirect under the page rules. I never added this. I have no idea why it’s there. I removed it, but it’s still in an infinite redirect.

Site is

hello justin55:
I have meet the same problem, and solve it now.

I will share my expirence to you , wish to help you.

the data flow as the follow:

browser → Cloudflare(dns proxy mode) ->aws cloudfront(bind two domain name, and use SAN ssl certificate) → s3

when I set dns to proxy, I will get infinity 301, if disable proxy, the problem will slove.
But I want to use Cloudflare proxy. At last I found the solution.

  1. on Cloudflare SSL/TLS setting page , use Flexible mode.
  2. set aws cloudfront protocol policy “HTTP and HTTPS”, default is “http to https”.

I have found a situation where when ssl certificates exist for multiple domains in middle cdn, and the middle cdn set policy “http to https”, there will be a 301 problem.

thanks 7booster1000. support actually got back to me right as you wrote me as well. not sure if it matters, but i’m not using aws. their solution was to change ssl from flexible to full, and that fixed it immediately.

no idea why this started happening without any action on my part.

The OP should definitely not use the suggested legacy encryption mode. Please do not mislead the OP and suggest insecure settings.

@justin55, you should change the mode to Full Strict. This will not only fix the issue, this is the only way to have a secure site. Full is not secure either I am afraid.


Your origin website maybe use https. So use full mode is right.
My website also meet 301 today :joy:

No, as mentioned, Full is not secure either. You need to select Full Strict.


i’ve changed it. thank you.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.