Index of/ after website

Hello, after adding website to Cloudflare on website I see Index of/ and nothing. I have read other threads with similar problems but nothing seems to help.

Greetings,

Thank you for asking.

I am afraid this is related to the configuration file/settings of your web server - Apache (.htaccess) or Nginx (vhost/nginx.conf) or some other.

Otherwise, I’d suggest you to check permissions (CHMOD) of the root and subdirectories.

Furthermore, contact your web hosting provider.

Before moving to Cloudflare, was your Website working over HTTPS connection?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

You could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  4. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Navigate to the Cloudflare dashboard → Caching → Configuration. Under the section Browser Cache TTL select “Respect Existing headers”.
Therefore, click on button “Purge Everything”.
Wair for a minute, then reload your website (hit F5 for refresh).
If not, try clearing your Web browser cache or try using another Web browser.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.