Increasing timeout because A timeout ocurred response

Hi there,
I can’t find any definite specifications but other internet forums appear to say that default timeout is 100 seconds for the web server to respond. We have Tableau server which can take longer than that to prepare a report ready to download, and are getting “A timeout occurred. Error code 524”. Does Cloudflare have a 100 second default timeout? Also I found this site developers Cloudflare which has increasing “HTTP response timeout” as an option. I can’t see that or find any documentation for how to find “HTTP response timeout”. The business I work for has “Pro Plan”, and other forums say you need Enterprise plan to be able to change response timeout. Would anyone be able to tell me if I am on the right track, or if there is somewhere simple to change “HTTP Response timeout” and if the default timeout is 100 seconds? Thanks, Shaun

You’re not going to be able to increase the timeout without an Enterprise account.

If altering your application isn’t an option, my guess is that, with requests taking more than 100 seconds, this isn’t a public-facing web server, right? Perhaps your best bet is to use an unproxied record (:grey: and not :orange:) for that server, so Cloudflare’s proxy won’t be involved.

Thanks heaps for your help, i40west. It is good to have someone confirm what I thought. I will go back to the business and tell them to make their analytics to work faster than 100 seconds. Thanks, Shaun

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.