Increased Googlebot response time problem

Hello!
Over the past month we have been experiencing a constant increase in our server response time to requests from Google search bots. This situation has nothing to do with the state of the server itself, only network infrastructure could be a reason for it. The most used Google bot sub-nets are 162.158.62.0/24 162.158.63.0/24 108.162.218.0/24 108.162.217.0/24 172.70.109.0/24 172.70.125.0/24. I’d like you to check the state and load of Cloudflare channels and make all possible steps to fix this. This is critical for our business. We’re using your services long time and hope you could help with this situation.
Thank you!

May I ask if you changed anything at Cloudflare dashboard which might include enabling or disabling the following features:

  1. Plan type change
  2. Security settings
  3. Firewall Rules
  4. Managed WAF Rules
  5. Automatic Signed Exchanges (SXGs)
  6. Early Hints
  7. Rocket Loader / Minify options
  8. Caching with or without using Page Rules
  9. APO - if using WordPress

On one of my Pro plan, I am seeing 1s for the time. I haven’t noticed until recently, but I don’t mind that as far as it’s a success HTTP 200 and as far as it might be Googlebot fetched the resource page which wasn’t in a cache, so the origin host firstly had to generate it and serve to a Googlebot. Therefore, I don’t know neither if it was a desktop or mobile bot, if so.
Furthermore, Crawl stats report doesn’t show any issues and no problems so far nor in the pas.t

Nevertheless, I even have the 4.5s on some other entities in Google search console, but everything is good so far.

I see it’s a zig-zag on the graph, guess it’s normal behaviour for each Website.

Thank you for response, I’ll try to answer your questions.

1 We have a Business plan already.
2-4 Nothing special in Security settings and Firewall rules. The server load is low and traffic is stable most time.
5-6 These options are turned off, may be I’ll try to use them
7. All options are turned on.
8. We have only one Page Rule for bypass caching
9. We don’t use a WordPress

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.