Increase Time out Setting

We are using this API to see the time out setting, which is set. How do we change the setting for the timeout with this API? See details below

https://api.cloudflare.com/client/v4/zones/023e105f4ecef8ad9ca31a8372d0c353/settings/proxy_read_timeout" \

We see the results below, shows timeout is set to 600 sec
{

"result": {

    "id": "proxy_read_timeout",

    "value": "600",

    "modified_on": "2022-01-25T16:59:11.740155Z",

    "editable": true

},

"success": true,

"errors": [],

"messages": []

https://api.cloudflare.com/#zone-settings-change-proxy-read-timeout-setting

I get an error when trying to run like this

https://api.cloudflare.com/XXXXXXX/settings-change-proxy-read-timeout-setting

May I ask are you on the Enterprise plan or not?

curl -X PATCH "https://api.cloudflare.com/client/v4/zones/XXX/settings/proxy_read_timeout" \
     -H "X-Auth-Email: [email protected]" \
     -H "X-Auth-Key: XXXXX" \
     -H "Content-Type: application/json" \
     --data '{"value":600}'
2 Likes

Hello,

I am an enterprise customer.

What kind of error? Could you provide a screenshot of the error (with sensitive information redacted)?

I see the below error, how ever the exact same details used for other API’s work fine.

@heath.a.knox I am not aware of this error. I’ve tested and I cannot reproduce this error on my end neither via my terminal neither by using Postman. Kindly, may I ask any other @MVP to try it out.

I do not see any recent incident related at the Cloudflare Status page (https://www.cloudflarestatus.com/) related to the Cloudflare API.

Can you share (but please mask/hide/redact the data) your screenshot from Postman app of what request have you sent/runned?

As an Enterprise account, may I ask have you tried writing to Cloudflare Support about this?

When I firstly runned GET:

curl -X GET "https://api.cloudflare.com/client/v4/zones/YOUR_ENT_ZONE/settings/proxy_read_timeout" \
     -H "X-Auth-Email: YOUR_EMAIL" \
     -H "X-Auth-Key: YOUR_GLOBAL_API_KEY" \
     -H "Content-Type: application/json"
{"result":{"id":"proxy_read_timeout","value":"100","modified_on":null,"editable"
:true},"success":true,"errors":[],"messages":[]}

After it, i runned PATCH and I got no error running it:

curl -X PATCH "https://api.cloudflare.com/client/v4/zones/YOUR_ENT_ZONE/settings/proxy_read_timeout" \
     -H "X-Auth-Email: YOUR_EMAIL" \
     -H "X-Auth-Key: YOUR_GLOBAL_API_KEY" \
     -H "Content-Type: application/json" \
     --data '{"value":200}'
{"result":"id":"proxy_read_timeout","value":"200","modified_on":"2022-02-09T16:02:27.981544Z","editable":true},"success":true,"errors":[],"messages":[]}

To re-check if applied, again GET:

curl -X GET "https://api.cloudflare.com/client/v4/zones/YOUR_ENT_ZONE/settings/proxy_read_timeout" \
     -H "X-Auth-Email: YOUR_EMAIL" \
     -H "X-Auth-Key: YOUR_GLOBAL_API_KEY" \
     -H "Content-Type: application/json"
{"result":{"id":"proxy_read_timeout","value":"200","modified_on":"2022-02-09T16:
02:27.981544Z","editable":true},"success":true,"errors":[],"messages":[]}
1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.