incorrect work of the CNAME record

I have S3 object storage and I store static files for my site in it. I want to make it possible to access these files by following the link static.myexample.com to do this, I added a CNAME record and specified a link to my S3 domain in it myexample-static-content.s3.example.com And for some reason when I go my own way static.myexample.com the loading page is s3.example.com A not myexample-static-content.s3.example.com What could be the matter?
I use a third-party S3 storage not from Amazon

CNAME is just a DNS pointer leading to the same IP as the target, the target still needs to be able to handle the source domain. For some S3 providers this is done by making the bucket name the same as the domain, for others you need to link the domain in the panel.

What is the provider?

1 Like

My S3 provider - Aeza

unfortunately, there is no function in my dashboard to link the repository to my domain. then I tried to make a redirect in order for all requests coming to static.myexample.com redirected to static.myexample.com/my-s3-name but I couldn’t set up redirect and I got an endless redirect
my rule looks like this:
(starts_with(http.host, “static.myexample.com”) and not ends_with(http.host, “my-s3-name”))
and dynamic redirect concat(“https://static.myexample.com/my-s3-name”, http.request.uri.path)
I’ve tried other settings for the rules, maybe I just don’t understand how these rules work correctly.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.