Incorrect permission for Update Custom Page URL

Hello,

I am trying to use the REST API to update the custom page URL: https://api.cloudflare.com/#custom-pages-for-a-zone-update-custom-page-url. I could successfully do so by providing the X-Auth-Email and X-Auth-Key, just as what the example shows.

However, when I tried using the new beta API Tokens (which allows me to create purpose-specific tokens), even if I created the token with the permission specified in the documentation (permission needed: #zone_settings:edit), I still received “{“success”:false,“errors”:[{“code”:9109,“message”:“Unauthorized to access requested resource”}],“messages”:,“result”:null}.” Only when I changed the permission to (Account->Account Settings->Edit) was I able to successfully update the custom page.

The command I was using: “curl -X GET “https://api.cloudflare.com/client/v4/zones/zoneid/custom_pages” -H “Authorization:Bearer authToken” -H “Content-Type:application/json”” where the zoneid and authToken are specific to my website/account.

Any help is appreciated and thanks in advance.

Edit: Sorry, the command is kind of wrong, it should have been something like "curl -X PUT “https://api.cloudflare.com/client/v4/zones/zoneid/custom_pages/500_errors --data {custom url},” but even the GET didn’t work.