Inconsistent responses when loading RSS data from one domain to another

Hi,

On the server side, we’re loading RSS data and are getting inconsistently “Connection refused” errors.
Using wget from CLI leads to the same error.
If we run the same command from our local computer, it works.

**wget https://blog.boutiqueducintre.com/test_domcontent.php**
--2024-04-08 15:46:48-- https://blog.boutiqueducintre.com/test_domcontent.php
Resolving [blog.boutiqueducintre.com](https://blog.boutiqueducintre.com/) ([blog.boutiqueducintre.com](https://blog.boutiqueducintre.com/))... 2606:4700:3030::ac43:9ecc, 2606:4700:3037::6815:3248, 104.21.50.72, ...
Connecting to [blog.boutiqueducintre.com](https://blog.boutiqueducintre.com/) ([blog.boutiqueducintre.com](https://blog.boutiqueducintre.com/))|2606:4700:3030::ac43:9ecc|:443... failed: Connection refused.
Connecting to [blog.boutiqueducintre.com](https://blog.boutiqueducintre.com/) ([blog.boutiqueducintre.com](https://blog.boutiqueducintre.com/))|2606:4700:3037::6815:3248|:443... failed: Connection refused.
Connecting to [blog.boutiqueducintre.com](https://blog.boutiqueducintre.com/) ([blog.boutiqueducintre.com](https://blog.boutiqueducintre.com/))|104.21.50.72|:443... failed: Connection refused.
Connecting to [blog.boutiqueducintre.com](https://blog.boutiqueducintre.com/) ([blog.boutiqueducintre.com](https://blog.boutiqueducintre.com/))|172.67.158.204|:443... failed: Connection refused.

What could be the reason for that?
Any idea is welcome.

Nicolas