Inconsistant ssl support

I am having a really hard time getting ssl to work consistently. It works on some pages and doesn’t on others. I have tried installing letsencrypt with certbot and that never worked even though it said it did. Then I tried again using virtualmin. That never worked, so I switched to Cloudflare as it works well with my other sites. I am trying to use a wordpress site hosted on GCP through virtualmin. The lock correctly appears on my back end of wordpress and doesn’t and says it is insecure on the front end of the site.

For starters, if you dont have a certificate on your server, install that first. community.letsencrypt.org will help you here. If you want to go the Cloudflare way you can install an Origin certificate.

im trying to use the origin one its not working even though its enabled.

Be aware the Origin one will only work in a proxied context.

If it doesnt work, post the domain name and the server IP address.

it is proxied with the cloud icon.

So you have a certificate on your server?

yes there is

So it works now?

no it still doesnt work

front end of wordpress. https://prnt.sc/srdw5q back end of wordpress https://prnt.sc/srdw8x . It was showing cloudflare on the backend before now its showing letsencrypt. I am trying to get either to show up on the front end.

With one-liners we wont get very far

This topic was automatically closed after 30 days. New replies are no longer allowed.