In "Page Rules" when we set "Cache Everything" it doesnot cache

Summary: In “Page Rules” when we set “Cache Everything” it doesnot cache

What is the domain name?
webdev4

Have you searched for an answer?
Yes

Please share your search results url:
Cannot find related content

Describe the issue you are having:
When we are trying to implement “Cache everything” we are facing instability in cache. The end result is to implement cache for pages and subpages so in page rules we used * in the path “path*”. We obseve inconsistentcy and please share docuemtn to implement full caching.

Cloudflare steps followed:

  1. Login to Cloudflare.
  2. click website webdev4
  3. select website
  4. Click “Rules”
  5. Click “Page rules”
  6. In page rules mention url with * say "path* " for the URL
  7. Additional settings are “Cache level” to Cache Everything and Edge cache TTL to “2 hours” and save

Details of the issue and steps followed on application:

  1. We validated this by setting path* on cloudfare to cache everything & Edge cache TTL to 2 hours the check started at 6:00 pm to 8:00 pm.

  2. After 6pm on the application admin side we changed content value to say value 1, value 2, value 3 and published one after other almost immediately, the last published value is value 3 on application. Between 6-8 pm when we refreshed browser it was fluctuating content on end user site with value 1, 2 and 3 simultaneously. Additionally we retried by giving absolute path of the URL and it was not caching at all. We observe stability issue in caching.

Issue: Can you please advise if there is any configuration issue and is there any recommended documents that we could follow to implement full caching.

If the site is webdev4.com, then it’s not on Cloudflare.

The site is co dot uk not an dot com

I suspect this should be webdev4.co.uk (as opposed to .com)

@sdayman Hope you are doing well. Can you please advise if you had time to review the above issue.?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.