Improving Core Web VItals

I want to ask the community a question that has long been a struggle. I operate the site and I have been struggling to improve the core web vitals on google search console to the green zones. The best I have come up with is “needs improvement” for desktop and “poor” for mobile. i.e. I need to get desktop to under 4s for desktop and 3s for mobile I think.

I have had a developer work on js and css to optimize it, I have all the optimization tools enabled on a free account for Cloudflare (Brotli, auto minify) and subscribe to the Wordpress APO service.

Still, I cannot seem to get the site to the point where it scores in the “good” zone for core web vitals. Any help or ideas would be greatly appreciated!!

thank you,

The instructions on Pagespeed Insights provide a list of things to improve. You may need to get that developer back to work though the list. As far as APO, it looks like it works in general, but if I force a reload or set my browser to disable cache, it’s a slow server response. It’s possible Google is also setting a no-cache that will bypass APO.

APO does work this way. If the client is sending a no-cache directive, Cloudflare will bypass the cache for the webpage.


And this pretty sure is the problem. The initial HTML file is set to “bypass” and therefore is very slow:

TTFB of 3.48s. Everything else is pretty fast. So the OP must configurate it’s APO properly to make it cache its initial request.

I can get a HIT with regular browsing, but take a look farther down on that BYPASS. You’ll see there’s a x-cache HIT from the back end, yet the server is still slow to respond.


There’s nothing to configure. APO does purposely bypass the cache if the user is doing a hard refresh (CTRL+SHIFT+R), has “Disable cache” checked in DevTools, or purposely sending cache-control: no-cache request header in their request. But as @sdayman mentioned, regular browsing won’t affect the cache for HTML pages.



Thanks for the tip! Do you know how I can “configurate the OP to make it cache its initial request”?

Sorry my mistake, I indeed was using “Disable Cache” in my Dev Console just like @erictung mentioned.


Is there anything I can do to speed up the site? For some reason even with APO enabled and all the optimization settings on (brotli, mirage, etc.), and CSS/JS optimized from my developer, Core web vitals for google search console are still not passing “needs improvement,” for mobile it’s not passing at all. My developer isn’t sure what the problem is. Happy to hire someone for help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.