Immediate updates don't work TTL is still applied


#1

I’ve just read about the Cloudflare resolver at IP 1.1.1.1

It says: “We can also support immediate updates, without having to wait for TTLs to expire.”

Now I’ve tried this with my load balanced records:

  1. I disabled one of my load balancer pools.
  2. Then I performed: nslookup LBrecord.example.com 1.1.1.1

I noticed that the address for this record wouldn’t change immediately.
It took about 30 seconds to get the new address (the TTL for this record is 30 seconds).

I then tried the same thing with a normal A record. I set the TTL to one hour and changed the address.
Even after 30 minutes the old address was still reported…

It appears that the immediate updates (before the TTL expires) do not work correctly.
When can we expect the immediate update functionality to be implemented?


#2

Thanks for the bug report! We will take a look.


#3

@dani
Thank you, do you have any update on this? Are you able to reproduce the same results?

I did some more testing with two machines which both use the PoP in Amsterdam and one machine which uses the PoP in London.

It seems that the 1.1.1.1 resolvers, in each PoP, cache a record for the time of the TTL.

My speculation is that records from the Cloudflare Authoritive DNS are also cached for the TTL period and the mechanism to invalidate these records is not working or not even implemented.
When we query in a different PoP we don’t make use of this cache and get the new results instantly.

Note: Not caching record from Cloudflare Authoritive DNS servers is NOT a proper solution as it would cause an increase in DNS requests to the Autoritive DNS server, in turn this will cause extra costs for customers with a load balancer pool as they pay per DNS request.