Imagnes not loading & 502 bad gateway

Hi. I have a problem where images on my main website refuse to load, see by yourself here. And on my wordpress website, I sometimes get a 502 bad gateway when going into it, although not always. See here

Looks like a configuration issue from Your host.

1 Like

I am using cpanel right now with whm on a dedicated server. Is there anything else that I need to configure? Is there maybe a wiki for getting started?

Check logs for Your domain in cpanel. It should tell You what is going on.

I will when ever I get home, just so you know. When I have gray cloud in DNS settings it works just fine.

Then it can also be Related to SSL, any chance your Cloudflare SSL/TLS app says SSL - Flexible? Maybe try using Full SSL mode?

I tried this. I first had full SSL, now I have full SSL strict, but nothing changed :confused: Can this have something to do with my htaccess file?. I do know that I have always https in there and caching. Since if Cloudflare too have caching, this might interfere

Try creating a page rule with Performance disabled for *.hostup.org if that lets You access site?

I mean, there is still a problem with main website too, hostup.org, the images wont load. Although blog is worse yes :smiley:

I can not access hostup.org or blog.hostup.org, getting 502 on both. 502 is usually from server side not Cloudflare side but if Your site works fine with Cloudflare disabled then you can try creating a page rule to narrow it down to the exact thing causing this.

it does not work for you at all now? It works just fine for me, try clearing cache/flushing DNS.

But yeah, I get the same problem as you when I have CDN on.

Seems like You disabled Cloudflare? (Assuming by checking ssl which now says issued by cpanel)

It’s mostly likely that the server is unable to talk to Cloudflare properly.

I think it has something to do with that I am using nginx for cpanel. GitHub - engintron/engintron: Engintron for cPanel/WHM is the easiest way to integrate Nginx on your cPanel/WHM server. Engintron will improve the performance & web serving capacity of your server, while reducing CPU/RAM load at the same time, by installing & configuring the popular Nginx webserver to act as a reverse caching proxy in front of Apache.

Engintron Documentation fixs it.

1 Like

example please I have the same problem

There should be a fix in that link I sent you. Although I just fixed it by installing an nginx server and hosted my website on there instead of cpanel.

This topic was automatically closed after 31 days. New replies are no longer allowed.