Images Transformed via URL aren't being delivered to my Webflow site

TLDR: Using Cloudflare Image Optimisation - Transform Images - Transform via URL. Zone is setup in Cloudflare. Images is enabled. URL is formatted correctly. Images still not being delivered to website.

I’m trying to setup an image pipeline with Cloudflare so I don’t have to pay so much for Cloudinary. I keep trying to use Cloudflare image optimisation and it always fails to work. I have also tried on other sites with the same results. I’ve setup the zone, turned on Image transformations for my zone, I’ve got a billing method connected, I’ve formatted the URL correctly. I’m 99% sure I’ve done everything right, but Cloudflare still isn’t delivering the images to my website. I set up the img tag src= with the zone name and without and still nothing works

Here’s the link to my webflow Project if it helps: https://preview.webflow.com/preview/6701?utm_medium=preview_link&utm_source=designer&utm_content=6701&preview=f77d307908c191ebe397c84badaa65e3&pageId=65f412446d40a2e47bd01869&workflow=preview

Pls help!!

You need to enable resizing from any origin if you are trying to transform an image from third-party zones

Thanks for your suggestion mate.

I’ve just tried this and it’s still not working. Any ideas why?

Can you provide url that doesn’t work for you?
the url in the preview goes to https://shorturl.at/dLSY3 which returns 403:

<Error>
<Code>AccessDenied</Code>
<Message>Request has expired</Message>
<X-Amz-Expires>300</X-Amz-Expires>
<Expires>2024-04-22T12:51:26Z</Expires>
<ServerTime>2024-04-24T12:28:18Z</ServerTime>
<RequestId>GET71S7ZZ4BAKWAV</RequestId>
<HostId>q7YXQV27TQEVlvP9IhtAOmzBGYJNKfHvu05gnYat6G8QHlsCNUC+thVZO494XjP5GNwZV2zGWjw=</HostId>
</Error>

@asemiglazov
Here’s the URL: https://uploads-ssl.webflow.com/645f50e9d2bb513e254f240d/66139f3af9039a2e918fa4dd_mx.webp

Just made a preview what appears for me in Webflow, below the code block.

there is a redirect from 6701local.com to www.6701local.com and www.6701local.com zone is not served by Cloudflare.

it cname’s to proxy-ssl-geo.webflow.com.

and in the end this page returns html https://www.6701local.com/cdn-cgi/image/width=80/https://uploads-ssl.webflow.com/645f50e9d2bb513e254f240d/66139f3af9039a2e918fa4dd_mx.webp

Sorry if dumb question, I am a noob here.
How would I fix it?

I think I’ve got it. Image is working
Thanks so much for your help bro!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.