Images show in Safari but not Chrome

I have a new Square.site which I want to use with my domain name harrybrand.co.uk (this used to be a WordPress site) with DNS by Cloudflare.

I’ve updated everything with my registrar and with Cloudflare and purged all cache both on Cloudflare and on my Mac’s Chrome but my site images are not showing.

Everything is fine in Safari however.

Please can someone help me understand the issue and how to fix it with really simple lay-person’s terminology?! I tried to find the answer here but am not getting it.

Thank you :slight_smile:

Hit f12 on the page.

Look at the console log and post or screenshot the errors you’re getting here.

Here’s one someone made earlier. But why is it happening in Chrome and not Safari? How can I fix it (simple instructions please) and will the fix affect how the site then appears in Safari? Thanks.

Your Website is on HTTPS and fetch-ing resources from HTTP URI.

I also got the redirection error from time to time when testing your website.

Can you re-code your HTML or change in databse all links from http to https?

Google Chrome with newer versions “force” HTTPS only and SSL. That could be the reason why.
Recently even FireFox too has an option “HTTPS only” in configuration.

What are your SSL option in Cloudflare dashboard?
Full SSL or Flexible SSL?

Moreover, have you checked “Always use HTPS” and “Automatic HTTPS redirection” option in Cloudflare dashboard?

You can even create .htaccess rule to redirect all requests from http to https.
If hardcoded in .php file or some other, try to change http to https as already stated.

2 Likes

Thanks for looking at it. The Square.site is a very simple drag & drop template which doesn’t give coding options. I’ve opened a ticket with Square for this issue HOWEVER my Square.site displayed fine on Chrome until I changed the DNS to point at my own domain and then all the images disappeared (but not on Safari). So maybe it’s a redirection issue and/or I’ve done something wrong with my DNS edits?

Update! I worked my way through the dashboard and I think the only thing I changed was from flexible to full SSL which seems to have sorted the problem, so thank you fritexvz :grinning:

PS I also ran a load time test on my site from the dashboard - it was showing that the last one was done a year ago on my old website so maybe this helped move things along too?

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.