Images offloaded to AWS S3 not running through HTTPS

dash-crypto
#1

Hi all. I offload all my media to an S3 bucket using WP Offload Media plugin. I have setup a CName record on Cloudflare to link to bucket, but whenever I try and open media I get a warning as images aren’t running with SSL. Is there a way to fix this on Cloudflares free plan with free SSL? Thanks!

#2

If you want a secure connection you need to make sure you have a valid HTTPS connection and certificate on your Amazon setup.

#3

Hi Sandro,

Thanks for your reply. I didnt know you could have a SSL certificate on an Amazon setup. Do you know how to do it?

Thanks again

#4

The link itself (generated on that page) needs to reference https://. There should be a setting in your plugin to change the scheme to https.

If there isn’t, you can add a header like so: (usually addable either in Wordpress, or via .htaccess):

Content-Security-Policy: upgrade-insecure-requests;

Or you can add the following meta tag to the html HEAD:

<meta http-equiv="Content-Security-Policy" content="upgrade-insecure-requests">
1 Like
#5

The Amazon documentation should have more on that.