Images not displaying on two pages

A couple of months ago all images stopped displaying on my Wordpress site. It turned out to be an issue with a caching/optimization plugin I was using in tandem with Cloudflare. I eliminated that plugin and the problem went away.

Well today the same thing is happening on just two pages. I have purged the cache but nothing has changed.

Anyone have any other ideas? Is it a new caching issue or something else entirely?

Site: and the pages in question are the “Commercial” and the “Healthcare” pages.

Thanks for your attention.

May I ask which WordPress caching plugin are you using?

Furthermore, are you using APO for WordPress?

Have you checked your SSL certificate? Is it still valid?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

I see some errors at the Network tab of my Developer Console (F12) from my Web browser.

When I have AdBlock/AdGuard, I see it’s trying to load png or jp(e)g, but fails - due this extensions.

Otherwise, seems they appear fine from my end.

UPDATE: Not so well. I got NS_BINDING_ABORTED for few of them after waiting for a bit more.

If I open them in a new tab, they load fine and I do see “HIT” for the cache, while some of them fails when loading a page.

After I hit refresh on a webpage, all are loaded fine.

I do see that they are .jpg or .png, but therefore something adds .webp to them.

UPDATE 2: preload-me iso-lazy-load height-ready thumb-lazy-load-show iso-layzr-loaded

You are using some script/plugin for lazy-load and possible some JavaScript or CSS code for “iso” grid system, right?

But, the upper/parent HTML element has got class iso-item and set the attribute opacity to the value 0 - which is why they do not appear visible.

When I change to 1 or remove this, I see all of them fine.

Could you re-check if you have got Rocket Loader option enabled at Cloudflare Dashboard?
Furthermore, if yes, try to disable it.

Next, try to disable Auto Minify for CSS, HTML and JavaScript.

Nevertheless, Purge the Cache by using Purge Everything from the Cloudflare dashboard.

See if anything changes.

Maybe something is in a conflict or minified, but it shouldn’t be to make it work and appear on scroll behaviour of the visitor in his Web browser - > isotope.


@fritex thanks for your reply! It took me a while to get back into this, but after poking around based on what you gave me I realized the problem is that even though I’d deactivated the offending plugin (WP Rocket) I hadn’t deleted it. So it was still causing conflicts. I deleted it entirely and everything is working fine now.

Thank you!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.