Images Not displaying of my site

Any images of my site www.kevaljaankari.com is not showing.

We enable the Cloudflare 16 hours ago, sometime it is showing not secure some time with https:// with no images.

What are the reason for these?

That is a mixed content error. Do a search on this forum or a search engine for that. There are lots of resources available about it!


Now getting the message “Your connection is not private”.

It is WordPress website could I install the Mixed Content Fixed Plugin?

If you use wordpress, there are various plugins that try to fix this, I am not too familiar with them but you could give it a try or refer to a help guide such as this:

is generally received when you choose to allow unsafe content on a site, when I visit your site, I just see the homepage with the mixed content errors.

Installed Plugins, but still images not appearing.

If ever I have to fix mixed content on Wordpress, i use https://wordpress.org/plugins/real-time-find-and-replace/, however it is more technical and doesn’t automatically do it… maybe some others will have better suggestions

Selected the content level of the mixed content fix plugin, images still not appearing.

@sdayman, do you have experience with this kind of thing in WP?

The images are loading for me right now.

My silver bullet for fixing mixed content is adding CSP to .htaccess:
Header always set Content-Security-Policy: upgrade-insecure-requests

p.s. Most of my WP sites were built with HTTPS, so there were never HTTP links. For others, I do the search-replace in the database.

2 Likes

Yes, they have started working now! Something worked :slight_smile:

1 Like

Just go to general setting make http to https inside WordPress Address (URL) & site address (URl)