Images not displaying after seting up cache

cache
#1

All the Images from the wordpress website https://www.infinityyachting.com.au/ goes missing after installing cloudflare cache plugin and setup cache. It is displayed when we do purge cache and after 2-3 days it goes missing again.
Please help me fix this problem.

0 Likes

Images suddenly gone missing on my site
#2

You appear to redirect all image requests to your main page, which of course cant work (that returns HTML for an image). Do you have any page rules set up? If not, that redirect likely comes straight from your server and you’d need to check its configuration for such a redirect.

0 Likes

#3

Our redirection is not for images , it is for non existing urls. The images are loading fine if we rename it through editing or clear cache from cloudflare. It is quiet clear that issue is with caching as the images are missing once the site is fully cached. Someone please help us

0 Likes

#4

Almost two weeks later it is difficult to tell, but your images were all redirected to your root page and consequently failed to load. Maybe you have made some changes in the meantime.

In fact they still do. For example https://www.infinityyachting.com.au/wp-content/uploads/2016/06/logo_light-e1548408112615.png

0 Likes

#5

The way it seems from your description it would appear as if none of your images exist, hence they are all redirected as per your configuration.

If that is the case you need to investigate why the images do not exist and how to change the configuration to make them “appear”.

0 Likes

#6

Sandro, the link you mentioned is not redirecting to home page. We tested with what you had mentioned it your first comment. And found out this: redirection doesn’t happens when we clear all cache.

So it is sure the issue is not redirection. Issue is something with cloudflare cache. We cleared the cache almost 2 hours before and the images were loading fine. Again the issue is coming up.

All our images exist in server. But something in cache is making it appear non existant. We had seen similar issues reported earlier as well by other people, but no solutions provided yet

0 Likes

#7

It is. Check out the status code at http://sitemeer.com/#https://www.infinityyachting.com.au/wp-content/uploads/2016/06/logo_light-e1548408112615.png

Again, you need to fix your configuration and get rid of these redirects.

0 Likes

#8

Please let us know what is wrong here?

0 Likes

#9

You need to check out the “Tech Stats” to get the status code.

Try clearing your browser cache. If you still get an image post the output of these two commands

ping www.infinityyachting.com.au
nslookup www.infinityyachting.com.au
0 Likes

#10

We tried in incognito mode and we are still getting the image.

Screenshot%20from%202019-01-25%2016-43-48

0 Likes

#11

From this screenshot you can clearly see the redirect.

Clear your browser cache and try again or try a different browser. If none of that works, try to purge Cloudflare’s cache.

0 Likes

#12

Could you please mark and show which part shows that redirect in screenshot?

0 Likes

#13

0 Likes

#14

If you cant reproduce it on any browser I’d suggest you purge the Cloudflare cache in the control panel, wait a minute, and try again. Even though unlikely, but maybe your PoP still has the image cached. Do you have any other proxies in place which could have cached it?

0 Likes

#15

Why is certain location have it as status 200 and certain 302 ??

0 Likes

#16

Because of different responses. You did not address my question about different proxies.

0 Likes

#17

We don’t use any proxies

0 Likes

#18

Well, there is an x-sucuri-cache header in your responses which would suggest another level of caching.

I assume you already purged your Cloudflare cache, right?

0 Likes

#19

Yes I purged it multiple times. After purging, few images are working fine for few hours. then again it is no show.

Could you please mention which file name have sucuri header

0 Likes

closed #20

This topic was automatically closed after 14 days. New replies are no longer allowed.

0 Likes