Images missing after moving to https from http on Cloudflare

Dear Friends,
I’m a novice/beginner and recently helped my travel writer wife to set-up a basic WP site somanytaveltales.com. The site was running fine for the last few months. However, since it was on HTTP, I installed Flexible SSL for Cloudflare and Really Simple SSL free version to convert it to HTTPS. However, after installing, most images on the site missing (except few). Few inputs 1) All images in the media folder still show HTTP permalink, even after loading new images after Cloudflare installation. Can’t even load pictures maually to the blog as it still loads as HTTP 2) Followed https://support.cloudflare.com/hc/en-us/articles/200169906-Troubleshooting-missing-images but it didn’t help. Also don’t have Rocket Loader, Mirage or other Cache plugins 2) Also getting attached error in Really Simple SSL
Please help
Rafiq Somani

Unable to reach mentioned site.

image

Thanks for instant reply. Just retry as I’m able to access it : https://somanytraveltales.com/
Yes, its goes on and off once in a while, again a new problem

This site appears hosted at GoDaddy and there is redirect loop due to misconfiguration from your end.

Before using Cloudflare, just enable Cloudflare Plugin instead any unofficial plugin.

It is not using Cloudflare nameservers at the moment.

https://dnschecker.org/#NS/somanytraveltales.com

  • Login to Cloudflare
  • Add your site
  • Update nameservers
  • Wait for few hours
  • Check again
1 Like

Thanks. I did the above steps and will wait for a few hours nows.
Btw as an interim step, when I de active Clouldflare Plugin and Really Simple SSL, the images on site come back, but I can’t load new ones and gallerias not moving.
If this doesn’t work can I go back to my original set-up with http, by deactivating Cloudflare. I’m a nervous husband now, as wife is saying why did I tinker a working site :slight_smile:

You’re using JetPack photon that seems not taking correct URL to proxy images.

A quick fix: Go to JetPack Settings > Disable Photon / Image accelerator thing. :slight_smile:

1 Like

Wow! you are simply brilliant. Your suggestion WORKED!!! and I’m saved :slight_smile:
God bless you my friend. You are really smart.
Only 2 small problems pending 1) now the images load very slow (maybe were fast due to Jetpack plugin image enhancement / lazy load features enabled. 2) after moving https every while, all my different browsers go thru some test loop and I have to sign I’m not a robot and verifications. This can be boring for visitors too.
Any suggestions? Sorry for being greedy

Also let me know if can do a feedback for your excellent advice somewhere? Not sure if there’s a process on this community site as this is was my first support/help post

I do appreciate your kind gesture. However, I can’t share any info. Thanks for understanding my privacy.

You can use this plugin for lazy loading.

  • Login to Cloudflare > Overview
  • Use the Toggle which says “I am under attack”, try setting OFF
    image
  • Now it will ask Security Level, you can keep low
1 Like

Thanks once again. God bless you!

1 Like