Images in R2 are being served via http/1.1

Images in an R2 bucket made public through a custom domain are beings served via http/1.1, not http/2 or 3. Here’s an example: https://behold.pictures/vhpmMq5YTcVwcPehcXTfqJWAHaZ2/hctEtthrslYK0FnGCCp0/18193227667165215/large.webp

http/2 and http/3 are both turned on in the dashboard for this domain, which is registered with Cloudflare and proxied.

Any ideas why this might be happening?

R2 Custom Domains are special and don’t care about your zone http version settings. Any Custom Domain added after 2023-03-16​​ should support http/2 though. If you added it before that date, deleting it and readding the Custom Domain under the bucket settings should enable http/2 on it.

2 Likes

Thanks for the reply — I set it up maybe 6 weeks ago, so it should definitely be using http/2. Is there anything else I can try?