Images from API not being retrieved


#1

Is there a rule to bypass everything and go directly to the server to retrieve files? I tried some of the rules and none of them are retrieving the photos I need for an API I have.

This API uses a JAVA Applet which is on another server to retrieve images and generate videos. It is not downloading the images.

I debugged the server itself and by pass the applet altogether and the server itself will retrieve the images; it has to be something to do with the security and not liking the Applet.

I have the IP for that server added to the white list as well.


#2

You’d have to hit the server’s IP address directly. Either by plugging in the IP address itself, or adding a :grey: A Record for a specially set up subdomain to your DNS and call that URL instead.

Is it possible you have Hotlinking disabled? It’s under the Scrape Shield tab at Cloudflare.


#3

Hot linking is not enabled; I will go the sub domain route :grey: to bypass Cloudflare. Thanks.


#4

As I’m thinking about a Rules approach, it could be a matter of setting a rule to Disable Security. I’ve opted for this in the past when I see a Firewall Event (under Cloudflare’s Firewall tab) for a specific asset.

While you’re at it, if Disable Security isn’t working, try disabling Performance, Apps, etc. for anything that might interfere. Which ones have you tried?


#5

I tried disabling all as many that dealt with security. Unless you have to wait until after setting up rules – it was easier to just setup a sub domain (done) and working.

Thanks for all the suggests and replies. I am almost there, where I can just let this run without anymore tweaks.