Images are missing and WP dashboard posts are blank


#1

I flipped the switch for the SSL last night on two domains. For one domain, the WP site works fine and displays fine. On the other domain, I have one WP site and one Zencart installation. The ZC installation shows up properly, but the WP one is troublesome:

  • most images are not showing on the front end
  • if I go in the dashboard, the posts themselves show as blank

The URL for those posts are still showing as http and not https. What might be missing? Is it just a delay to populate something? Or do I have to flip something else?
Should I link to the site here?


#3

OK someone suggested to change the site URL in the general settings to https and it seems to fix the problem. However, this puzzles me since the other WP site still shows an http URL in the General settings, yet, everything displays correctly.

But now, although everything displays correctly, I cannot log into my dashboard as I get
This page isn’t working
creationcassel.com redirected you too many times.

Help!


#4

Which SSL setting are you using? If it’s Flexible, the URL in your General Settings should be http.

This plugin should help straighten out Flexible SSL issues:


#5

Yes, it was the Flexible SSL.
In trying to log back in, I chose to disable the SSL, (which still required me to edit in the DB but I am logged in now) so right now, I don’t have it (when I enabled it, earlier, I was losing all my images). So what are my next steps? Re-enabling the “Always use HTTPS” and “Automatic HTTPS Rewrites”? or something else first, and then use that plugin?


#6

If your site is now set to http in WP General Settings, add that plugin and activate it. Then change your Cloudflare Crypto settings for HTTPS.


#7

Should I change BOTH the “Always use HTTPS” and “Automatic HTTPS Rewrites” to enable them? or just one?

And on the site that showed no issue so far, should I disable those two settings and start with the plugin?

Also, that particular plugin has not been updated in 2 years. Will it work with the current WP version? or would another one be more appropriate?


#8

That plugin still works well.

If you’re using HTTPS, then you should enable both of those Crypto settings.

For the site that’s working, leave it alone for now.


#9

Making sure i won’t mess anything, the steps should be:
1- use the plugin
2- enable the SSL with https in the Crypto settings

Is the change going to be immediate or will need to populate somehow and make the site work oddly for a bit?

Also, although Cloudflare offers those SSL, my host also does. Would it be easier to use the host’s SSL? They say it tends to not work well with CF. Which one is more likely to work or not work?


#10

Yep. Those would be the correct steps. Changes will be immediate.

But now that you mention it, if you can get your Host’s SSL working, you won’t need to use Flexible. You’ll be able to use Full (Strict) which is the best option.


#11

What would be the steps to use my host’s SSL? I am using InMotion and they specifically said that it seems to not play well with CF, so I am unsure where the problem would be or how to avoid it. Do you have any suggestion?


#12

That doesn’t sound encouraging. Stick with Flexible SSL.


#13

Thanks.
Now, i have the roadmap for my WP site, but I also have a Zencart site.
What would be the process for that one?


#14

That should be easier. Wordpress seems to get confused by Flexible SSL.

Install Zencart without the Cloudflare proxy. If that domain is already added to Cloudflare, make sure all DNS entries are set to :grey: so it’s a straight connect. Then turn on Flexible SSL and the two HTTPS options in Crypto when it’s all done.


#15

Actually, i am not sure how much easier it would be since both sites are sub-domains of the same domain. How can I do that on both sites on a single domain?


#16

If you :grey: the DNS entry for the zencart subdomain, you’ll be off to a good start.


#17

Ok i’ll see how i can do that :slight_smile: