Image Resizing returns 409 Conflict

Hello everyone! :slight_smile:

We noticed that for most images we now get a 409 Conflict Error returned.

We currently don’t understand why, since the “source image” (the one that should be resized) is available.

We have looked into our billing details. Everything looks fine so far.
However, we noticed that images stopped getting resized once we hit 100k image resizing requests this month.

We are not sure if this has to do with anything to do with the legacy or new billing plans Cloudflare introduced.
According to the information of our billing details, we should be able to get 50k included, then be charged $9 for every additional 50k resizing requests.
Since everything is displayed as “Paid”, we don’t know if this is a billing issue or a technical issue.

Anyone experienced the similar issues?
Any help is greatly appreciated.

Many thanks in advance and best regards,
Lukas

Hey, do you use Images (store images on Cloudflare) or Transformations(aka Image resizing)?

I suspect 409 Conflict error is from Images, and it means that you can’t upload an image with the same Id.

1 Like

Thanks for the quick response!

We use Image Resizing only.

Example:

  • URL pointing to Cloudflare Image Proxy. Fails with 409: https://images.journey-deluxe.de/cdn-cgi/image/width=384,quality=75,format=auto/api/image?src=https%3A%2F%2Fi.travelapi.com%2Flodging%2F1000000%2F50000%2F48400%2F48315%2F8477f037_z.jpg
  • Source image. Succeeds and returns 200: https://i.travelapi.com/lodging/1000000/50000/48400/48315/8477f037_z.jpg

This setup worked perfectly as expected for more than half a year so far and stopped working as of yesterday. Suspiciously close to 100k image resizing requests served.

That’s why we also mentioned the billing details in this topic. But we can’t say for sure since everything looks ok in our dashboards/billing details on Cloudflare.

was https://images.journey-deluxe.de/api/image?src=https%3A%2F%2Fi.travelapi.com%2Flodging%2F1000000%2F50000%2F48400%2F48315%2F8477f037_z.jpg always working through redirects? it returns 307 with location: https://i.travelapi.com/lodging/1000000/50000/48400/48315/8477f037_z.jpg

Hey, I just wanted to jump in and say our site is having the same issue.

Any URL going through the image resize returns Could not fetch the image — the server returned HTTP error 409 Conflict

1 Like

Yes, we always used the redirects so far. As far as we know, we need to tell the Cloudflare Image Proxy that the requested file exists and redirect it to the requested file.

We didn’t change that code part on our side. It worked up until 24.01.2024, then it reached 100k image resizing requests, then it seemed to have stopped working (could be a coincide, though, it is somewhat suspicious :eyes:).

Hi,

Thanks for sharing this issue.

We have an incident active now for this issue:

2 Likes

It was a technical issue with the latest release. The issue has been fixed. Sorry for the inconvenience.

2 Likes

No worries and thanks for the quick response and fix! :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.