Image not showing until i open the src url

when i first open the website it wont show the image
and will only show after i open the src url
how do i make it so it will show the image without
opening the src url??

Can you share the URL of the example? Might be hotlink or some HTTP(S) issue :thinking:

Before moving to Cloudflare, was your Website working over HTTPS connection?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

2 Likes

website with image
https://yuku.cf/creations/kerosuke.html
image src
https://yuku.cf/files/kerosuke.png

i use Cloudflare to use https
i have flexible selected

also when i try to open the image link when the image is broken,
it will say 403 forbidden
and only works after i open the link in http

That error is coming from your server:

You will have to figure out why your server is blocking those requests.

Probably the origin server blocking some requests, probably rate-limiting Cloudflare. I tried multiple times with curl and got different results.

HTTP/2 200 
content-type: image/png
content-length: 25202
last-modified: Sun, 06 Nov 2022 12:09:19 GMT
etag: "1b80cee-6272-5eccc2d2db33d"
cache-control: max-age=14400
cf-cache-status: HIT
age: 241
accept-ranges: bytes
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
vary: Accept-Encoding
server: cloudflare
alt-svc: h3=":443"; ma=86400, h3-29=":443"; ma=86400

But other times it does not:

HTTP/2 403 
content-type: text/html; charset=iso-8859-1
cf-cache-status: BYPASS
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
vary: Accept-Encoding
server: cloudflare
content-encoding: gzip
alt-svc: h3=":443"; ma=86400, h3-29=":443"; ma=86400

Does it work with Cloudflare disabled or with development mode on?

1 Like

The issue is rather trivial. The actual issue is this

@secondlyuku, you currently have no encryption and should change that to Full Strict, as @fritex already suggested.

i tried both disabling and turning on development mode but didnt work…
maybe its a problem with the server im using (xfree)

ok so i changed the proxy status to dns only which showed the image…
but when i turn back on the proxy it broke again…

Did you fix the encryption mode?

You seem to have fixed your encryption mode :+1:t2:, but unfortunately your server also seems to be insecure.

$ curl https://yuku.cf/creations/kerosuke.html --connect-to ::[ORIGIN_IP]
curl: (60) SSL: no alternative certificate subject name matches target host name 'yuku.cf'
More details here: https://curl.haxx.se/docs/sslcerts.html

You best pause Cloudflare for now - Pause Cloudflare · Cloudflare Fundamentals docs - and contact your host to secure your site. Once your site is loading fine on HTTPS, you can enable Cloudflare again and it should work as well.

i resulted in changing the server to infinityfree which fixed the problem

Is your encryption mode Full Strict now?

idk it seems like i cant set it to full (strict) with infinityfree
but i set it to full (not strict)

Then I am afraid it is insecure. It needs to be Full Strict.

nvm i got it to work

But your site still is insecure.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.