Image files not cached even though I set TTL

My Page Speed Test shows the subdomain where are I kept all my imagesare not cached. image.allnoorthailand.com is TTL=none. Can anyone tell me why and what changes I must do to get it cached.

I have setup all my images in subdomain image.allnoorthailand.com as my origin server does not allow images upload in main domain.

I have then setup TTL as 14400 and set up Page rules to allow for caching of image subdomain.

Would you mind providing a link?

My website is at [http://www.allnoorthailand.com]

Oh, gotcha. You aren’t actually using Cloudflare, didn’t look too well at the images before.

You need to set the CF nameservers at your registrar, not at your DNS.

1 Like

What is CF nameserver?

You mean I go to Godaddy (where I buy the domain) and set the nameservers there?

That is correct - see https://www.godaddy.com/help/change-nameservers-for-your-domain-names-664

I have already changed ns server to CF through Godaddy. But the cached TTL for images in subdomain http://image.allnoorthailand.com still remains none. See below:

Did you just now bypass Cloudflare?

1 Like

They seem fixed to me now… I see cache hits.

1 Like

But the Cache TTL is still none. Why?
TTL%20none3

The mobile score is still a poor 44.

Unfortunately can’t check right now, hopefully soon, if not in a few hours.

I don’t know what Page Speed sees, but all the images on my end have a policy to cache on the browser for 8 days attached.

The only recommendation I can do, completely unrelated is: enable HTTPS.

Maybe you’ve changed something, but I’m seeing good cache headers. Or that PageSpeed test is wrong. GTMetrix’s PageSpeed stats don’t show problems with Cache TTL.


https://gtmetrix.com/reports/allnoorthailand.com/hHimILTx

This topic was automatically closed after 30 days. New replies are no longer allowed.