Image does not display anymore on IE/edge/mobile after setting up cloudflare

my site: https://smartjingling.com/

I set up cloudflare according to some recommended settings on youtube. page rule is as below. Rocket Loader™ is disabled. In chrome, all pages look well, but on mobile phones, IE and edge, no image, logo, menu symbol is shown. I read some past blogs here. Not sure it is related to jetpack. Since I did at the same time deactivated jetpack plugin. I would really appreciate if you can give me some suggestions since I am just a beginner with WP.

sorry for the confusion, i just found out that images donot display on chrome either.

Your Images are getting loaded through this domain:
box2275.temp.domains

This domain is not getting routed through CloudFlare and therefore this problem is not CloudFlare related.

Your JS and CSS are getting loaded through:

tricia.ns.cloudflare.com
braden.ns.cloudflare.com

which most probably are your NameServer, but not your CDN Domains.

CloudFlare is no regular CDN and therefore it does not have any Pull and Push Zones.
Please do not rewrite your URLs if you use CloudFlare, it is not needed.

THanks @M4rt1n M4rt1n. Sorry I can read what you mean, but can you please tell me how can I change this? THe feedback I got from Bluehost is:

Thank you for contacting support, I would suggest you to disable any caching plugin to check if they are causing the website to load without images, i would also suggest you to contact cloudflare support on this issue

I just disabled WP rocket to try. It seems some pages appearing normal on my laptop at least: see: https://smartjingling.com/contact/

thanks again for your help again.

Your pages are cached with “Cache Everything” so everytime you change something you have to clear that cache to make it taking effect.

As you use Cache everything I do not kniw where the core problem is, but somewhere as “CDN Domain” you used your CloudFlare NameServers which is wrong, thats why your site is not getting displayed right. You have to know on your own where you set this up.

by the way, now I disabled Wp Rocket, some pages appeared OK on my laptop as well as on the mobile, see https://smartjingling.com/about-us/. But the home page does not load anymore… So any tips on where the problem lies?

I see it worked :slight_smile:

It is probably WP Rocket. I did copy the CloudFlare NameServers in the CDN settings. I enabled WP Rocket and disabled the page rule, the main page does load OK now in the web browser with all the images. But only some images display on the mobile. Is there any solution for displaying the images on the mobile the same as in the web browser. Thank you so much for your help! You saved my day so far!

I still see the strange Image with this URL is getting loaded:

https://box2275.temp.domains/~smartji1/wp-content/uploads/2018/01/skyscraper-3302027_1920.jpg

So check where this comes from, as this image does not exist on this server.
Everything else you have to check with your Themeprovider, as this forum is no general support.

Once everything is working you can turn on Cache Everything again, to speed up your site

@M4rt1n Thanks a lot! I checked my media library, all the images I uploaded there don’t have this URL. So I really have no clue where this image. The address looks like the temporary address I got from bluehost before I connected my domain. I will ask Bulehost about this. Really appreciated your help!!!

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.