Im not able to purchase a domain name

Continually receiving an error message when trying to register a new domain name. Tried 2 different payment methods and still getting the same result.

Im not able to purchase a domain name. The error message is continually “We’re sorry, something went wrong with that. Please review your purchase details and try again, or contact support for assistance.”

Sorry for that less than informative error message. Can you clear browser cookies & cache or try incognito mode and see if you’re successful?

same thing is happening in incognito. Won’t go through. What’s weird it, the domain will now show up in my list of domains, but it shows up as “Expired” and when I click on it it takes me to a 404 page

1 Like

Thank you, am able to reproduce that issue. I see the expiry date of today. Did you just purchase the 2 affected domains today?

hi @jake32 now I show one of the two domains I mentioned as active if I click manage from the domains page, with an expiry of May 16, 2024. Although it’s still showing as expired today on the domains page.

I suspect this is just a timing issue in updating the dashboard domain details but will check back in a bit to ensure it does work.

Hi @jake32 yes, my colleague @salvador was able to identify a delay to update the domain. Can you let us know when it shows as active in your account?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.