I'm getting 404 html page after adding Domain on Cloudflare

I added my site indiecostudio.com on cloudflare and later entered the nameserver on goDaddy account.

Now when i enter the my domain then it redirects on 404.html page - https://indiecostudio.com/404.html

Where is the issue?

How can i solve this 404 redirection? Please help!!

I see that it redirects to HTTPS. Was it working with HTTPS before you added the site to Cloudflare?

yes before adding to cloudfalre, it was working fine with https

Are you sure?

What certificate were you using? If your server IP address ends in .238, it doesn’t have a valid certificate for the site.

yes, it was working fine on https.
here’s original site also working on ssl (didn’t setup on cloudfalre yet) - maddermuch.com

the ssl certificate is from let’s encrypt…

so after adding site on cloudflare this 404 happens.

Does your server IP address end in .238?

yes .238

Sorry, but the evidence does not show a Let’s Encrypt certificate. I suggest you use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com. The link is in the lower right corner of that page. Give it five minutes to take effect, then make sure site is working as expected with HTTPS. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

2 Likes

yes now i have paused the cloudflare please check.

what’s next?

Now it’s a double mystery. It’s working, but it’s not Let’s Encrypt.

Is your SSL/TLS mode here set to Full (Strict)?

this is the options tha currently activated or disabled:

What does “Keep websites secured” do?

You also didn’t answer this:

This is in the SSL/TLS section for your domain at dash.cloudflare.com

1 Like

yes it was full strict.

but i also tried other to full and flexible.

Let me just explian it once agin

this is the domain - indiecostudio.com works with https because an ssl (free ssl added on it).

Now for CDN I have added this domain on cloudflare.

I added cloudflare namerservers on godaddy and proceed for next setting. SSL/TLS is (full strict).

but now domains shows 404.

As I said…double-mystery, for the reasons stated.

Do you see those 404s in the webserver log?

no there is log on webserver regarding this, that’s why I’m confused!!

Sorry, my mistake. I misspelled the hostname, as shown in my screenshot.

Now it’s a slightly different double-mystery: Why doesn’t the origin show Let’s Encrypt, and why the 404 errors.

It looks like you were using Bluehost before. And it’s been on Cloudflare before. Were you using Bluehost’s Cloudflare integration?

sorry for late reply
yes, earlier using Bluehost’s Cloudflare integration

That most likely explains what you’re seeing. Bluehost probably never removed your domain from their Cloudflare account, so when you :orange: that hostname, it’s going through Cloudflare and still using Bluehost’s settings.

You’ll have to ask Bluehost to fully release your domain from their Cloudflare SaaS configuration.

ok i’ll check this.

1 Like